summaryrefslogtreecommitdiffstats
path: root/gui/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gui/CMakeLists.txt')
-rw-r--r--gui/CMakeLists.txt41
1 files changed, 17 insertions, 24 deletions
diff --git a/gui/CMakeLists.txt b/gui/CMakeLists.txt
index 7db12e36e..2a071e12c 100644
--- a/gui/CMakeLists.txt
+++ b/gui/CMakeLists.txt
@@ -10,8 +10,10 @@
#################################################
include_directories(
- ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/core
${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
${TQT_INCLUDE_DIRS}
)
@@ -22,38 +24,29 @@ link_directories(
##### install headers ###########################
-install( FILES
- dummy-gui.h
- DESTINATION ${INCLUDE_INSTALL_DIR} )
+install(
+ FILES
+ polkit-tqt-gui-action.h
+ polkit-tqt-gui-actionbutton.h
+ polkit-tqt-gui-actionbuttons.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}
+)
##### polkit-tqt-gui (shared) #########################
tde_add_library( polkit-tqt-gui SHARED AUTOMOC
- SOURCES ${polkit_tqt_MOCS}
- dummy-gui.cpp
+ SOURCES ${polkit_tqt_gui_MOCS}
+ polkit-tqt-gui-action.cpp
+ polkit-tqt-gui-actionbutton.cpp
+ polkit-tqt-gui-actionbuttons.cpp
VERSION 0.0.0
- LINK ${TQT_LIBRARIES}
+ LINK ${TQT_LIBRARIES} ${POLKIT_LIBRARIES} polkit-tqt-core-shared
DESTINATION ${LIB_INSTALL_DIR}
)
-## set(polkit_tqt_gui_SRCS
-## polkittqt1-gui-action.cpp
-## polkittqt1-gui-actionbutton.cpp
-## polkittqt1-gui-actionbuttons.cpp
-## )
-##
-## target_link_libraries(polkit-tqt-gui-1
-## ${TQT_TQTCORE_LIBRARY}
-## ${TQT_TQTGUI_LIBRARY}
-## ${TQT_TQTDBUS_LIBRARY}
-## ${POLKIT_LIBRARIES}
-## polkit-tqt-core-1
-## )
-##
## set_target_properties(polkit-tqt-gui-1 PROPERTIES VERSION ${POLKITTQT-1_LIBRARY_VERSION}
## SOVERSION ${POLKITTQT-1_ABI_VERSION}
-## DEFINE_SYMBOL MAKE_POLKITTQT1_LIB)
-##
-## install(TARGETS polkit-tqt-gui-1 ${INSTALL_TARGETS_DEFAULT_ARGS})
+## DEFINE_SYMBOL MAKE_POLKIT_TQT_LIB)
+##