summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2025-01-17 21:39:35 +0900
committerMichele Calgaro <[email protected]>2025-01-19 21:24:40 +0900
commit3aac4e821aeb0b02d258114feca2a8578d423d2c (patch)
treedb94995752f26b9c58da74fcfc3de78e0cc1f3d1 /setup.py
parent00b7bb523740cf5a6f01b24022b815c763202450 (diff)
downloadpytdeextensions-3aac4e821aeb0b02d258114feca2a8578d423d2c.tar.gz
pytdeextensions-3aac4e821aeb0b02d258114feca2a8578d423d2c.zip
Fix FTBFS caused by 'mkpath' returning nothingr14.1.x
Signed-off-by: Michele Calgaro <[email protected]> (cherry picked from commit ecdb0099bd14fc440a09219bd3df5672208c483c)
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index fa41586..8690ffa 100755
--- a/setup.py
+++ b/setup.py
@@ -318,6 +318,7 @@ class InstallLibpythonize(Command):
return self.outfiles
def mkpath(self, name, mode=0o777):
- return dir_util.mkpath(name, mode, dry_run=self.dry_run)
+ dir_util.mkpath(name, mode, dry_run=self.dry_run)
+ return name
main()