summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am60
1 files changed, 0 insertions, 60 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
deleted file mode 100644
index 8ab4c37..0000000
--- a/src/Makefile.am
+++ /dev/null
@@ -1,60 +0,0 @@
-# set the include path for X, qt and KDE
-INCLUDES = $(all_includes)
-
-# these are the headers for your project
-
-
-# let automoc handle all of the meta source files (moc)
-METASOURCES = AUTO
-
-messages: rc.cpp
- $(EXTRACTRC) `find . -name \*.ui -o -name \*.rc` > rc.cpp
- $(XGETTEXT) *.cpp -o $(podir)/qalculate_tde.pot
-
-KDE_ICON = AUTO
-
-#########################################################################
-# APPLICATION SECTION
-#########################################################################
-# this is the program that gets installed. it's name is used for all
-# of the other Makefile.am variables
-bin_PROGRAMS = qalculate-tde
-
-# the application source, library search path, and link libraries
-qalculate_tde_SOURCES = buttonwithindexsignal.cpp kqalculate.cpp \
- main.cpp preferences.cpp qalculatebuttonwithdata.cpp qalculateconvertnumberbasesdialog.cpp \
- qalculateconvertunitsdialog.cpp qalculatedatasetsdialog.cpp qalculatedecimalsdialog.cpp qalculateeditdataobjectdialog.cpp \
- qalculateeditdatasetdialog.cpp qalculateeditfunctiondialog.cpp qalculateeditmatrixvectordialog.cpp qalculateeditnamesdialog.cpp \
- qalculateeditunitdialog.cpp qalculateeditunknownvariabledialog.cpp qalculateeditvariabledialog.cpp qalculateexportcsvdialog.cpp \
- qalculateexpressionedit.cpp qalculatefunctionsdialog.cpp qalculateimportcsvdialog.cpp qalculateinsertfunctiondialog.cpp \
- qalculateinsertmatrixvectordialog.cpp qalculate_tde_utils.cpp qalculateperiodictabledialog.cpp qalculateplotdialog.cpp \
- qalculateprecisiondialog.cpp qalculatepreferencesdialog.cpp qalculatesetbasedialog.cpp \
- qalculateunitsdialog.cpp qalculatevariablesdialog.cpp qalculateresultdisplay.cpp
-
-qalculate_tde_LDFLAGS = $(KDE_RPATH) $(all_libraries)
-qalculate_tde_LDADD = $(LIB_TQT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) $(LIB_TDEIO) -lcln
-
-# this is where the desktop file will go
-shelldesktopdir = $(xdg_appsdir)
-shelldesktop_DATA = qalculate_tde.desktop
-
-# this is where the shell's XML-GUI resource file goes
-shellrcdir = $(kde_datadir)/qalculate_tde
-shellrc_DATA = qalculate_tdeui.rc
-
-
-noinst_HEADERS = preferences.h qalculateinsertfunctiondialog.h qalculateinsertmatrixvectordialog.h \
- buttonwithindexsignal.h qalculateexpressionedit.h qalculateconvertnumberbasesdialog.h \
- qalculatebuttonwithdata.h qalculatesetbasedialog.h \
- qalculatevariablesdialog.h qalculatefunctionsdialog.h qalculateunitsdialog.h \
- qalculateeditunknownvariabledialog.h qalculatedecimalsdialog.h qalculateconvertunitsdialog.h \
- qalculateprecisiondialog.h qalculateeditunitdialog.h qalculateeditnamesdialog.h \
- qalculateeditfunctiondialog.h qalculateplotdialog.h qalculateimportcsvdialog.h \
- qalculateexportcsvdialog.h qalculatepreferencesdialog.h qalculateeditmatrixvectordialog.h \
- qalculatedatasetsdialog.h qalculateeditdatasetdialog.h qalculateeditdataobjectdialog.h \
- qalculateresultdisplay.h
-
-install-exec-local:
- install -d $(DESTDIR)$(bindir)
- rm -f $(DESTDIR)$(bindir)/qalculate
- $(LN_S) qalculate-tde $(DESTDIR)$(bindir)/qalculate