summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in282
1 files changed, 0 insertions, 282 deletions
diff --git a/configure.in b/configure.in
deleted file mode 100644
index eabb1af..0000000
--- a/configure.in
+++ /dev/null
@@ -1,282 +0,0 @@
-dnl =======================================================
-dnl FILE: ./admin/configure.in.min
-dnl =======================================================
-
-dnl This file is part of the KDE libraries/packages
-dnl Copyright (C) 2001 Stephan Kulow ([email protected])
-
-dnl This file is free software; you can redistribute it and/or
-dnl modify it under the terms of the GNU Library General Public
-dnl License as published by the Free Software Foundation; either
-dnl version 2 of the License, or (at your option) any later version.
-
-dnl This library is distributed in the hope that it will be useful,
-dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
-dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-dnl Library General Public License for more details.
-
-dnl You should have received a copy of the GNU Library General Public License
-dnl along with this library; see the file COPYING.LIB. If not, write to
-dnl the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
-dnl Boston, MA 02110-1301, USA.
-
-# Original Author was [email protected]
-# I lifted it in some mater. (Stephan Kulow)
-# I used much code from Janos Farkas
-
-dnl Process this file with autoconf to produce a configure script.
-
-AC_INIT(acinclude.m4) dnl a source file from your sub dir
-
-dnl This is so we can use kde-common
-AC_CONFIG_AUX_DIR(admin)
-
-dnl This ksh/zsh feature conflicts with `cd blah ; pwd`
-unset CDPATH
-
-dnl Checking host/target/build systems, for make, install etc.
-AC_CANONICAL_SYSTEM
-dnl Perform program name transformation
-AC_ARG_PROGRAM
-
-dnl Automake doc recommends to do this only here. (Janos)
-AM_INIT_AUTOMAKE(soundkonverter, 0.3.7) dnl searches for some needed programs
-
-KDE_SET_PREFIX
-
-dnl generate the config header
-AM_CONFIG_HEADER(config.h) dnl at the distribution this done
-
-dnl Checks for programs.
-AC_CHECK_COMPILERS
-AC_ENABLE_SHARED(yes)
-AC_ENABLE_STATIC(no)
-KDE_PROG_LIBTOOL
-
-dnl for NLS support. Call them in this order!
-dnl WITH_NLS is for the po files
-AM_KDE_WITH_NLS
-
-KDE_USE_TQT(3.2.0)
-AC_PATH_KDE
-dnl =======================================================
-dnl FILE: configure.in.in
-dnl =======================================================
-
-#MIN_CONFIG(3.2.0)
-
-dnl PACKAGE set before
-AC_C_BIGENDIAN
-AC_CHECK_KDEMAXPATHLEN
-
-
-###############################################################################
-# BEGIN CDPARANOIA CHECK
-###############################################################################
-#
-#AC_CHECK_HEADER([cdda_interface.h], [with_cdparanoia=yes], [with_cdparanoia=no])
-#
-#if test "$with_cdparanoia" != "yes" ; then
-# soundkonverter_error_nocdparanoia=yes
-# DO_NOT_COMPILE="$DO_NOT_COMPILE soundkonverter"
-# no_soundkonverter=yes
-#
-# echo ""
-# echo "-----------------------------------------"
-# echo "ERROR: Could not find cdparanoia headers."
-# echo "-----------------------------------------"
-# echo ""
-#
-# AC_MSG_ERROR([could not find cdparanoia headers])
-#fi
-#
-###############################################################################
-# END CDPARANOIA CHECK
-###############################################################################
-
-
-dnl -------------------------------------
-dnl cdparanoia check
-dnl -------------------------------------
-
-AC_CHECK_HEADERS(cdda_interface.h, have_paranoia="yes", have_paranoia="no" )
-
-dnl ----------------------------------
-dnl Can soundkonverter be compiled?
-dnl ----------------------------------
-
-if test x$have_paranoia != xyes; then
- DO_NOT_COMPILE="$DO_NOT_COMPILE soundkonverter"
- no_paranoia=yes
-fi
-
-###############################################################################
-# BEGIN TAGLIB CHECK
-###############################################################################
-
-TAGLIB_REQ_VERSION="1.4.0";
-AC_DEFUN([VERSION_TO_NUMBER], [`$1 | awk 'BEGIN { FS = "."; } { printf "%d", ([$]1* 1000 + [$]2) * 1000 + [$]3;}'`])
-
-AC_PATH_PROG(TAGLIB_CONFIG, taglib-config, no)
-
-if test "x$TAGLIB_CONFIG" = "xno" ; then
- soundkonverter_error_notaglib=yes
- DO_NOT_COMPILE="$DO_NOT_COMPILE soundkonverter"
- no_soundkonverter=yes
-else
- AC_DEFINE(HAVE_TAGLIB, 1, [have TagLib])
- taglib_includes=[`$TAGLIB_CONFIG --cflags`]
- taglib_libs=[`$TAGLIB_CONFIG --libs`]
- taglib_version=[`$TAGLIB_CONFIG --version`]
-
- if test VERSION_TO_NUMBER(echo $taglib_version) -lt VERSION_TO_NUMBER(echo $TAGLIB_REQ_VERSION); then
- soundkonverter_error_taglibold=yes
- DO_NOT_COMPILE="$DO_NOT_COMPILE soundkonverter"
- no_soundkonverter=yes
- fi
-fi
-
-AC_SUBST(taglib_includes)
-AC_SUBST(taglib_libs)
-
-###############################################################################
-# END TAGLIB CHECK
-###############################################################################
-
-
-###############################################################################
-# BEGIN MP4V2 CHECK
-###############################################################################
-# m4a/aac tag reading and writing needs libmp4v2 from faad2 or better mpeg4ip
-
-AC_ARG_WITH(mp4v2,
- AC_HELP_STRING([--with-mp4v2],[build soundkonverter with M4A/AAC tag support from mp4v2/faad2]),
- [have_mp4v2=$withval],
- [have_mp4v2=no]
-)
-
-AC_ARG_WITH(mp4v2-dir,
- AC_HELP_STRING([--with-mp4v2-dir],[path to mp4v2 [default=/usr]]),
- [mp4v2_dir="$withval"],
- [mp4v2_dir=/usr]
-)
-
-if test "$have_mp4v2" != "no"; then
- AC_LANG_SAVE
- AC_LANG_CPLUSPLUS
- ac_cxxflags_save=$CXXFLAGS
- CXXFLAGS="$CXXFLAGS -I$mp4v2_dir/include"
- ac_ldflags_save=$LDFLAGS
- LDFLAGS="$LDFLAGS -L$mp4v2_dir/lib"
-
- # not even everyone using faad2 has <systems.h>
- if ! test -f config.h; then
- echo "#include \"confdefs.h\"" > config.h
- fi
- ac_cppflags_save=$CPPFLAGS
- CPPFLAGS="$CPPFLAGS -I."
- AC_CHECK_HEADERS(systems.h)
- AC_CHECK_HEADERS([mp4.h], [have_mp4_h=yes], [],
- [#ifdef HAVE_SYSTEMS_H
- # include <systems.h>
- #endif
- ])
-
- AC_CHECK_LIB( mp4v2, MP4Read, have_mp4v2=yes, have_mp4v2=no )
-
- if test "$have_mp4v2" = "yes" -a "$have_mp4_h" = "yes"; then
- AC_DEFINE(HAVE_MP4V2, 1, [have mp4v2])
- MP4V2_INCLUDES="-I$mp4v2_dir/include"
- MP4V2_LIBS="-L$mp4v2_dir/lib -lmp4v2"
- else
- have_mp4v2=no
- fi
-
- CPPFLAGS=$ac_cppflags_save
- CXXFLAGS=$ac_cxxflags_save
- LDFLAGS=$ac_ldflags_save
- AC_LANG_RESTORE
-fi
-
-AC_SUBST(MP4V2_INCLUDES)
-AC_SUBST(MP4V2_LIBS)
-
-AM_CONDITIONAL(with_mp4v2, [test x$have_mp4v2 != xno ])
-
-###############################################################################
-# END MP4V2 CHECK
-###############################################################################
-
-KDE_CREATE_SUBDIRSLIST
-AC_CONFIG_FILES([ Makefile ])
-AC_CONFIG_FILES([ doc/Makefile ])
-AC_CONFIG_FILES([ doc/en/Makefile ])
-AC_CONFIG_FILES([ po/Makefile ])
-AC_CONFIG_FILES([ src/Makefile ])
-AC_CONFIG_FILES([ src/amarokscript/Makefile ])
-AC_CONFIG_FILES([ src/metadata/Makefile ])
-AC_CONFIG_FILES([ src/metadata/aac/Makefile ])
-AC_CONFIG_FILES([ src/metadata/ape/Makefile ])
-AC_CONFIG_FILES([ src/metadata/asf/Makefile ])
-AC_CONFIG_FILES([ src/metadata/audible/Makefile ])
-AC_CONFIG_FILES([ src/metadata/m4a/Makefile ])
-AC_CONFIG_FILES([ src/metadata/mp4/Makefile ])
-AC_CONFIG_FILES([ src/metadata/optimfrog/Makefile ])
-AC_CONFIG_FILES([ src/metadata/rmff/Makefile ])
-AC_CONFIG_FILES([ src/metadata/speex/Makefile ])
-AC_CONFIG_FILES([ src/metadata/trueaudio/Makefile ])
-AC_CONFIG_FILES([ src/metadata/wav/Makefile ])
-AC_CONFIG_FILES([ src/metadata/wavpack/Makefile ])
-AC_CONFIG_FILES([ src/pics/Makefile ])
-AC_CONFIG_FILES([ src/pluginloader/Makefile ])
-AC_CONFIG_FILES([ src/plugins/Makefile ])
-AC_CONFIG_FILES([ src/plugins/format_infos/Makefile ])
-AC_CONFIG_FILES([ src/plugins/mime_types/Makefile ])
-AC_CONFIG_FILES([ src/plugins/plugins/Makefile ])
-AC_CONFIG_FILES([ src/plugins/rohling/Makefile ])
-AC_OUTPUT
-# Check if KDE_SET_PREFIX was called, and --prefix was passed to configure
-if test -n "$kde_libs_prefix" -a -n "$given_prefix"; then
- # And if so, warn when they don't match
- if test "$kde_libs_prefix" != "$given_prefix"; then
- # And if kde doesn't know about the prefix yet
- echo ":"`tde-config --path exe`":" | grep ":$given_prefix/bin/:" 2>&1 >/dev/null
- if test $? -ne 0; then
- echo ""
- echo "Warning: you chose to install this package in $given_prefix,"
- echo "but KDE was found in $kde_libs_prefix."
- echo "For this to work, you will need to tell KDE about the new prefix, by ensuring"
- echo "that TDEDIRS contains it, e.g. export TDEDIRS=$given_prefix:$kde_libs_prefix"
- echo "Then restart KDE."
- echo ""
- fi
- fi
-fi
-
-if test x$GXX = "xyes" -a x$kde_have_gcc_visibility = "xyes" -a x$kde_cv_val_qt_gcc_visibility_patched = "xno"; then
- echo ""
- echo "Your GCC supports symbol visibility, but the patch for Qt supporting visibility"
- echo "was not included. Therefore, GCC symbol visibility support remains disabled."
- echo ""
- echo "For better performance, consider including the Qt visibility supporting patch"
- echo "located at:"
- echo ""
- echo "http://bugs.kde.org/show_bug.cgi?id=109386"
- echo ""
- echo "and recompile all of Qt and KDE. Note, this is entirely optional and"
- echo "everything will continue to work just fine without it."
- echo ""
-fi
-
-if test "$all_tests" = "bad"; then
- if test ! "$cache_file" = "/dev/null"; then
- echo ""
- echo "Please remove the file $cache_file after changing your setup"
- echo "so that configure will find the changes next time."
- echo ""
- fi
-else
- echo ""
- echo "Good - your configure finished. Start make now"
- echo ""
-fi