summaryrefslogtreecommitdiffstats
path: root/trinity-apps/koffice-libs/koffice-libs-14.0.12.ebuild
diff options
context:
space:
mode:
authorormorph <[email protected]>2022-04-30 20:47:27 +0300
committerSlávek Banko <[email protected]>2022-05-01 16:23:29 +0200
commit336d8ce82c00a00153a823a187dbc8e0bcf2c7a1 (patch)
tree920bb9b62e96c92b2a5a7e99352e68afb2783ce8 /trinity-apps/koffice-libs/koffice-libs-14.0.12.ebuild
parent1c8d53512742aab368c0f7e9973604eaa54b43ba (diff)
downloadtde-packaging-gentoo-336d8ce82c00a00153a823a187dbc8e0bcf2c7a1.tar.gz
tde-packaging-gentoo-336d8ce82c00a00153a823a187dbc8e0bcf2c7a1.zip
Added version 14.0.12
Signed-off-by: ormorph <[email protected]>
Diffstat (limited to 'trinity-apps/koffice-libs/koffice-libs-14.0.12.ebuild')
-rw-r--r--trinity-apps/koffice-libs/koffice-libs-14.0.12.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/trinity-apps/koffice-libs/koffice-libs-14.0.12.ebuild b/trinity-apps/koffice-libs/koffice-libs-14.0.12.ebuild
new file mode 100644
index 00000000..af39141d
--- /dev/null
+++ b/trinity-apps/koffice-libs/koffice-libs-14.0.12.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Copyright 2022 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_NAME="koffice"
+TRINITY_MODULE_TYPE="applications/office"
+TRINITY_BUILD_ADMIN="yes"
+TRINITY_SUBMODULE="lib lib/kwmf lib/store lib/kofficecore
+ lib/kofficeui lib/kopainter
+ lib/kopalette lib/kotext lib/kformula
+ lib/koproperty lib/kross filters/olefilters
+ filters/xsltfilter filters/generic_wrapper
+ kounavail servicetypes mimetypes pics
+ templates autocorrect interfaces plugins tools"
+TSM_EXTRACT_ALSO="filters doc kchart"
+
+inherit flag-o-matic trinity-meta-2
+
+DESCRIPTION="Shared KOffice libraries for TDE [Trinity]"
+HOMEPAGE="http://trinitydesktop.org/"
+
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE=""
+
+DEPEND="
+ ~trinity-base/tdelibs-${PV}
+"
+
+RDEPEND="$DEPEND"
+
+src_prepare() {
+ trinity-meta-2_src_prepare
+}
+
+src_configure() {
+ append-cxxflags "-std=c++11"
+ export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:${TDEDIR}/$(get_libdir)/pkgconfig
+ myconf=(--with-extra-libs=${TDEDIR}/$(get_libdir)
+ --with-extra-includes=${TDEDIR}/include/arts
+ --disable-scripting)
+
+ trinity-econf ${myconf[@]}
+}