summaryrefslogtreecommitdiffstats
path: root/trinity-apps/kxmleditor
diff options
context:
space:
mode:
authorormorph <[email protected]>2021-11-15 22:06:35 +0300
committerormorph <[email protected]>2021-11-16 00:22:50 +0300
commit9f59a1d0c834bc706d6e74f0a0dc9f026e935b41 (patch)
treedbe2babfd8aea5f985063e94dcfa22679c93526f /trinity-apps/kxmleditor
parentffbff856abb47b6fb62cdd430211c67f67478c5b (diff)
downloadtde-packaging-gentoo-9f59a1d0c834bc706d6e74f0a0dc9f026e935b41.tar.gz
tde-packaging-gentoo-9f59a1d0c834bc706d6e74f0a0dc9f026e935b41.zip
Added ebuilds for stable version 14.0.11
Signed-off-by: ormorph <[email protected]>
Diffstat (limited to 'trinity-apps/kxmleditor')
-rw-r--r--trinity-apps/kxmleditor/Manifest1
-rw-r--r--trinity-apps/kxmleditor/kxmleditor-14.0.11.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/trinity-apps/kxmleditor/Manifest b/trinity-apps/kxmleditor/Manifest
new file mode 100644
index 00000000..58ec6322
--- /dev/null
+++ b/trinity-apps/kxmleditor/Manifest
@@ -0,0 +1 @@
+DIST kxmleditor-trinity-14.0.11.tar.xz 736172 BLAKE2B 5cd2721760909587ccacb3acff946f9aca96d189226564557aa1c92b215ea9385345145f2abb8c3c605d4be157a5f5978ea90bf3269c4575a34b726b6da0b7a9 SHA512 586cc9b3b434c7854bdd39e31cbaf88a979f4201a607562a5dc851dcfb65b5e298f3bd0aa296666c4ae8c2be117e1ce91ab7a9674000e51bfa487a9df83c3424
diff --git a/trinity-apps/kxmleditor/kxmleditor-14.0.11.ebuild b/trinity-apps/kxmleditor/kxmleditor-14.0.11.ebuild
new file mode 100644
index 00000000..6db8f1b4
--- /dev/null
+++ b/trinity-apps/kxmleditor/kxmleditor-14.0.11.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021 Gentoo Authors
+# Copyright 2021 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="de fr pl"
+
+TRINITY_MODULE_TYPE="applications/development"
+inherit trinity-base-2
+
+DESCRIPTION="XML editor for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TRANSLATIONS=ON
+ )
+ trinity-base-2_src_configure
+}