summaryrefslogtreecommitdiffstats
path: root/trinity-base/kfax/kfax-14.1.0.ebuild
diff options
context:
space:
mode:
authorormorph <[email protected]>2023-04-22 11:30:51 +0300
committerormorph <[email protected]>2023-04-22 21:42:10 +0300
commit3e6b95222ab4ee71b69a570f49e1e887b166a83e (patch)
tree30fa95df5cd70e135890939da86d325d10bf0dca /trinity-base/kfax/kfax-14.1.0.ebuild
parent70fc50722d8c4c3d7c566fb8ab9e7d4376eea1bf (diff)
downloadtde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.tar.gz
tde-packaging-gentoo-3e6b95222ab4ee71b69a570f49e1e887b166a83e.zip
Adding version 14.1.0
Signed-off-by: ormorph <[email protected]>
Diffstat (limited to 'trinity-base/kfax/kfax-14.1.0.ebuild')
-rw-r--r--trinity-base/kfax/kfax-14.1.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/trinity-base/kfax/kfax-14.1.0.ebuild b/trinity-base/kfax/kfax-14.1.0.ebuild
new file mode 100644
index 00000000..b6f7f080
--- /dev/null
+++ b/trinity-base/kfax/kfax-14.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Copyright 2020-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_NAME="tdegraphics"
+TRINITY_MODULE_TYPE="core"
+TRINITY_SUBMODULE="kfax kfaxview"
+TRINITY_HANDBOOK="optional"
+TSM_EXTRACT_ALSO="kviewshell"
+inherit trinity-meta-2
+
+DESCRIPTION="Trinity G3/G4 fax viewer"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DEPEND="~trinity-base/kviewshell-${PV}"
+RDEPEND="${DEPEND}"
+
+src_prepare(){
+ sed -i "s/BUILD_KVIEWSHELL OR BUILD_KDVI OR BUILD_KFAX/BUILD_KVIEWSHELL/" "${S}/doc/man/CMakeLists.txt" || die
+ trinity-meta-2_src_prepare
+}