summaryrefslogtreecommitdiffstats
path: root/trinity-base/kscd/kscd-14.0.11.ebuild
diff options
context:
space:
mode:
authorormorph <[email protected]>2021-11-15 22:06:35 +0300
committerormorph <[email protected]>2021-11-16 00:22:50 +0300
commit9f59a1d0c834bc706d6e74f0a0dc9f026e935b41 (patch)
treedbe2babfd8aea5f985063e94dcfa22679c93526f /trinity-base/kscd/kscd-14.0.11.ebuild
parentffbff856abb47b6fb62cdd430211c67f67478c5b (diff)
downloadtde-packaging-gentoo-9f59a1d0c834bc706d6e74f0a0dc9f026e935b41.tar.gz
tde-packaging-gentoo-9f59a1d0c834bc706d6e74f0a0dc9f026e935b41.zip
Added ebuilds for stable version 14.0.11
Signed-off-by: ormorph <[email protected]>
Diffstat (limited to 'trinity-base/kscd/kscd-14.0.11.ebuild')
-rw-r--r--trinity-base/kscd/kscd-14.0.11.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/trinity-base/kscd/kscd-14.0.11.ebuild b/trinity-base/kscd/kscd-14.0.11.ebuild
new file mode 100644
index 00000000..0969c1f0
--- /dev/null
+++ b/trinity-base/kscd/kscd-14.0.11.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Foundation
+# Copyright 2021 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+TRINITY_MODULE_NAME="tdemultimedia"
+TRINITY_MODULE_TYPE="core"
+TSM_EXTRACT_ALSO="libkcddb/"
+
+inherit trinity-meta-2
+
+DESCRIPTION="Trinity mixer GUI"
+if [[ ${PV} != *9999* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DEPEND="x11-libs/libXext
+ ~trinity-base/libkcddb-${PV}"
+
+src_configure() {
+ mycmakeargs=(
+ -DBUILD_LIBKCDDB=yes
+ )
+
+ trinity-meta-2_src_configure
+}
+
+src_install() {
+ trinity-meta-2_src_install
+
+ #Junk all the files that overlap with libkcddb.
+ #It would be cleaner not to let them install at all, but I wasn't
+ #able to pull that off.
+ rm -r ${D}/usr/trinity/14/share/apps/tdeconf_update/
+ rm -r ${D}/usr/trinity/14/share/config.kcfg/libkcddb.kcfg
+ rm -r ${D}/usr/trinity/14/share/applications/tde/libkcddb.desktop
+ rm -r ${D}/usr/trinity/14/include/
+ rm -r ${D}/usr/trinity/14/lib64/
+}