summaryrefslogtreecommitdiffstats
path: root/dev-tqt/tqtinterface/tqtinterface-14.0.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tqt/tqtinterface/tqtinterface-14.0.6.ebuild')
-rw-r--r--dev-tqt/tqtinterface/tqtinterface-14.0.6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-tqt/tqtinterface/tqtinterface-14.0.6.ebuild b/dev-tqt/tqtinterface/tqtinterface-14.0.6.ebuild
new file mode 100644
index 00000000..22cd2684
--- /dev/null
+++ b/dev-tqt/tqtinterface/tqtinterface-14.0.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="7"
+TRINITY_MODULE_TYPE="dependencies"
+TRINITY_MODULE_NAME="${PN}"
+
+inherit trinity-base
+
+DESCRIPTION="Interface and abstraction library for TQt and Trinity"
+HOMEPAGE="http://trinitydesktop.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64"
+SLOT="0"
+
+#Note: for the sake of easier maintenance, building against QT3
+# (no T) is no longer a thing.
+DEPEND="~dev-tqt/tqt-${PV}
+ !!x11-libs/tqtinterface"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ export QTDIR="/usr/tqt3"
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DUSE_QT3=ON
+ -DQT_PREFIX_DIR="$QTDIR"
+ )
+
+ cmake-utils_src_configure
+}