summaryrefslogtreecommitdiffstats
path: root/trinity-base/klaptopdaemon/klaptopdaemon-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'trinity-base/klaptopdaemon/klaptopdaemon-9999.ebuild')
-rw-r--r--trinity-base/klaptopdaemon/klaptopdaemon-9999.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/trinity-base/klaptopdaemon/klaptopdaemon-9999.ebuild b/trinity-base/klaptopdaemon/klaptopdaemon-9999.ebuild
index 153e91d8..b8fd6525 100644
--- a/trinity-base/klaptopdaemon/klaptopdaemon-9999.ebuild
+++ b/trinity-base/klaptopdaemon/klaptopdaemon-9999.ebuild
@@ -3,21 +3,24 @@
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-TRINITY_MODULE_NAME="tdeutils"
+TRINITY_MODULE_NAME="tdeutils"
inherit trinity-meta-2
-DESCRIPTION="KLaptopdaemon - Trinity battery monitoring and management for laptops."
+DESCRIPTION="Trinity battery monitoring and management for laptops"
IUSE="xscreensaver"
-DEPEND="x11-libs/libXtst
+RDEPEND="
+ x11-libs/libXtst
xscreensaver? ( x11-libs/libXScrnSaver )
- virtual/os-headers"
-RDEPEND="${DEPEND}"
+"
+DEPEND="${RDEPEND}
+ virtual/os-headers
+"
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DWITH_DPMS=ON
-DWITH_XSCREENSAVER="$(usex xscreensaver)"
)