From 94ec1d06986a97431ffc44951e92b075da19b93b Mon Sep 17 00:00:00 2001
From: ormorph <roma251078@mail.ru>
Date: Sun, 28 Apr 2024 17:23:47 +0300
Subject: Add new TDE-14.1.2

Signed-off-by: ormorph <roma251078@mail.ru>
(cherry picked from commit 30335515923be5f5ee02981121d2cdb6ad89978d)
---
 trinity-apps/kvpnc/kvpnc-14.1.2.ebuild | 44 ++++++++++++++++++++++++++++++++++
 1 file changed, 44 insertions(+)
 create mode 100644 trinity-apps/kvpnc/kvpnc-14.1.2.ebuild

(limited to 'trinity-apps/kvpnc/kvpnc-14.1.2.ebuild')

diff --git a/trinity-apps/kvpnc/kvpnc-14.1.2.ebuild b/trinity-apps/kvpnc/kvpnc-14.1.2.ebuild
new file mode 100644
index 00000000..38759300
--- /dev/null
+++ b/trinity-apps/kvpnc/kvpnc-14.1.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Copyright 2020-2024 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_EXTRAGEAR_PACKAGING="yes"
+TRINITY_HANDBOOK="optional"
+
+TRINITY_LANGS="bg ca da de es fr hu it ja nl pl pt_BR ru sk sv tr zh_CN"
+TRINITY_MODULE_TYPE="applications/internet"
+inherit trinity-base-2
+
+DESCRIPTION="VPN clients frontend for TDE"
+HOMEPAGE="https://trinitydesktop.org/"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="14"
+if [[ ${PV} != *9999* ]] ; then
+	KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="cisco libreswan +openvpn pptpd smartcard strongswan"
+
+# Other VPN clients will be added by request, controlled over USE.
+#		 If you miss any, please let us know!
+
+DEPEND="
+	dev-libs/libgcrypt
+	sys-apps/net-tools"
+RDEPEND="${DEPEND}
+	cisco? ( net-vpn/vpnc )
+	libreswan? ( net-vpn/libreswan )
+	openvpn? ( net-vpn/openvpn )
+	pptpd? ( net-vpn/pptpd )
+	smartcard? ( dev-libs/openct )
+	strongswan? ( net-vpn/strongswan )"
+
+src_configure() {
+	local mycmakeargs=(
+		-DBUILD_TRANSLATIONS=ON
+	)
+
+	trinity-base-2_src_configure
+}
-- 
cgit v1.2.1