From 271fc0de62480ffa8a1525e07b833079c96ca6bd Mon Sep 17 00:00:00 2001
From: ormorph <roma251078@mail.ru>
Date: Fri, 27 Oct 2023 13:50:17 +0300
Subject: Release R14.1.1 added

Signed-off-by: ormorph <roma251078@mail.ru>
(cherry picked from commit 18d39ed9f062321b596258a9137f10b3e93b71e0)
---
 trinity-base/kcheckpass/kcheckpass-14.1.1.ebuild | 28 ++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
 create mode 100644 trinity-base/kcheckpass/kcheckpass-14.1.1.ebuild

(limited to 'trinity-base/kcheckpass/kcheckpass-14.1.1.ebuild')

diff --git a/trinity-base/kcheckpass/kcheckpass-14.1.1.ebuild b/trinity-base/kcheckpass/kcheckpass-14.1.1.ebuild
new file mode 100644
index 00000000..314c95bb
--- /dev/null
+++ b/trinity-base/kcheckpass/kcheckpass-14.1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Copyright 2020-2023 The Trinity Desktop Project
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+TRINITY_MODULE_NAME="tdebase"
+TRINITY_MODULE_TYPE="core"
+inherit trinity-meta-2
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication."
+if [[ ${PV} != *9999* ]] ; then
+	KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+IUSE="pam"
+
+RDEPEND="pam? ( trinity-base/tdebase-pam )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+	local mycmakeargs=(
+		-DWITH_SHADOW=ON
+		-DWITH_PAM="$(usex pam)"
+		-DKCHECKPASS_PAM_SERVICE=tde
+	)
+
+	trinity-meta-2_src_configure
+}
-- 
cgit v1.2.1