summaryrefslogtreecommitdiffstats
path: root/arch/tde-deps/libvisual/PKGBUILD
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2024-10-18 04:08:19 +0200
committerSlávek Banko <[email protected]>2024-10-24 04:08:19 +0200
commit88660b1b05e92c192c13144e4536d541af0e44fa (patch)
treed63ff1d27889d53b2c644eba8bc880683280cdf3 /arch/tde-deps/libvisual/PKGBUILD
parent3dca8bbc0b29007611c7ef89a7f16bc925fb9216 (diff)
downloadtde-packaging-88660b1b05e92c192c13144e4536d541af0e44fa.tar.gz
tde-packaging-88660b1b05e92c192c13144e4536d541af0e44fa.zip
ArchLinux: Update for final R14.1.3.
Add pkgbuilds for several applications. Add pkgbuild for libvisual dependency. Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'arch/tde-deps/libvisual/PKGBUILD')
-rw-r--r--arch/tde-deps/libvisual/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/arch/tde-deps/libvisual/PKGBUILD b/arch/tde-deps/libvisual/PKGBUILD
new file mode 100644
index 000000000..37ff821c6
--- /dev/null
+++ b/arch/tde-deps/libvisual/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Jan de Groot <[email protected]>
+
+pkgname=libvisual
+pkgver=0.4.2
+pkgrel=2
+pkgdesc="Abstraction library that comes between applications and audio visualisation plugins"
+arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'powerpc64le')
+url="https://sourceforge.net/projects/libvisual/"
+license=('LGPL')
+depends=('glibc' 'sdl12-compat')
+source=(https://github.com/Libvisual/libvisual/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz)
+sha256sums=('63085fd9835c42c9399ea6bb13a7ebd4b1547ace75c4595ce8e9759512bd998a')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+}