summaryrefslogtreecommitdiffstats
path: root/gentoo/trinity-base/korganizer/korganizer-9999.ebuild
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2019-11-19 17:45:28 +0100
committerSlávek Banko <[email protected]>2019-11-19 17:45:28 +0100
commite6636bd5d6280d92996bd70b744e8a29e54c7e18 (patch)
tree014989bddcbc22c7a8d4dafa7b78f3e55b184718 /gentoo/trinity-base/korganizer/korganizer-9999.ebuild
parent4b7471734323c7cb5bdc129857c94041418c81b5 (diff)
downloadtde-packaging-e6636bd5d6280d92996bd70b744e8a29e54c7e18.tar.gz
tde-packaging-e6636bd5d6280d92996bd70b744e8a29e54c7e18.zip
Gentoo: Initial import of an ebuilds tree
from Fat-Zer's (Alexander Golubev) repository. Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'gentoo/trinity-base/korganizer/korganizer-9999.ebuild')
-rw-r--r--gentoo/trinity-base/korganizer/korganizer-9999.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/gentoo/trinity-base/korganizer/korganizer-9999.ebuild b/gentoo/trinity-base/korganizer/korganizer-9999.ebuild
new file mode 100644
index 000000000..b9f24c9b0
--- /dev/null
+++ b/gentoo/trinity-base/korganizer/korganizer-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI="5"
+TRINITY_MODULE_NAME="tdepim"
+
+inherit trinity-meta
+
+DESCRIPTION="A Personal Organizer for Trinity"
+KEYWORDS=""
+IUSE+=" exchange"
+COMMON_DEPEND="
+ >=trinity-base/kgantt-${PV}:${SLOT}
+ >=trinity-base/libtdepim-${PV}:${SLOT}
+ >=trinity-base/libtdenetwork-${PV}:${SLOT}
+ >=trinity-base/libkcal-${PV}:${SLOT}
+ >=trinity-base/ktnef-${PV}:${SLOT}
+ >=trinity-base/libkmime-${PV}:${SLOT}
+ >=trinity-base/libkholidays-${PV}:${SLOT}
+ >=trinity-base/certmanager-${PV}:${SLOT}
+ >=trinity-base/libkpimidentities-${PV}:${SLOT}
+ >=trinity-base/kaddressbook-${PV}:${SLOT}
+ exchange? ( >=trinity-base/libkpimexchange-${PV}:${SLOT} )"
+# >=trinity-base/tdepim-tderesources-${PV}:${SLOT}
+
+DEPEND+=" ${COMMON_DEPEND}"
+RDEPEND+=" ${COMMON_DEPEND}"
+
+TSM_EXTRACT_ALSO="certmanager/lib/
+ libemailfunctions/
+ libkcal/
+ libkholidays/
+ libkpimidentities/
+ libtdepim/
+ libkmime/
+ kdgantt/
+ kmail/"
+
+TSM_EXTRACT_ALSO+=" libkpimexchange/core/" # required for USE=exchange
+
+src_configure () {
+ mycmakeargs=(
+ $(cmake-utils_use_with exchange EXCHANGE )
+ )
+ trinity-meta_src_configure
+}