summaryrefslogtreecommitdiffstats
path: root/redhat/applications/misc/kcmldap/kcmldap.spec
diff options
context:
space:
mode:
Diffstat (limited to 'redhat/applications/misc/kcmldap/kcmldap.spec')
-rw-r--r--redhat/applications/misc/kcmldap/kcmldap.spec21
1 files changed, 19 insertions, 2 deletions
diff --git a/redhat/applications/misc/kcmldap/kcmldap.spec b/redhat/applications/misc/kcmldap/kcmldap.spec
index 68af31207..b44904f44 100644
--- a/redhat/applications/misc/kcmldap/kcmldap.spec
+++ b/redhat/applications/misc/kcmldap/kcmldap.spec
@@ -18,7 +18,7 @@
# TDE variables
%define tde_epoch 2
%if "%{?tde_version}" == ""
-%define tde_version 14.1.0
+%define tde_version 14.1.2
%endif
%define tde_pkg kcmldap
%define tde_prefix /opt/trinity
@@ -72,13 +72,21 @@ BuildRequires: gcc-c++
BuildRequires: pkgconfig
# ACL support
+%if 0%{?mdkver}
+BuildRequires: %{_lib}acl-devel
+%else
BuildRequires: libacl-devel
+%endif
# IDN support
BuildRequires: libidn-devel
# OPENSSL support
+%if 0%{?mdkver}
+BuildRequires: %{_lib}openssl-devel
+%else
BuildRequires: openssl-devel
+%endif
# SUSE desktop files utility
%if 0%{?suse_version}
@@ -92,8 +100,12 @@ BuildRequires: brp-check-trinity
# OPENLDAP support
%if 0%{?rhel} >= 6 || 0%{?fedora} || 0%{?mdkversion} || 0%{?mgaversion}
+%if 0%{?mdkver}
+BuildRequires: lib64ldap-devel
+%else
BuildRequires: openldap-devel
%endif
+%endif
%if 0%{?suse_version}
BuildRequires: openldap2-devel
%endif
@@ -115,8 +127,12 @@ BuildRequires: libheimdal-devel
# UDEV support
%if 0%{?fedora} || 0%{?mdkversion} || 0%{?mgaversion} || 0%{?suse_version} || 0%{?rhel} >= 6
%define with_tdehwlib 1
+%if 0%{?mdkversion} || 0%{?mgaversion}
+BuildRequires: %{_lib}udev-devel
+%else
BuildRequires: libudev-devel
%endif
+%endif
# LIBCOM_ERR support
%if 0%{?fedora} || 0%{?suse_version} || 0%{?rhel} >= 6
@@ -152,6 +168,7 @@ This is a TDE control center module to manage TDE connections to Kerberos realms
%dir %{tde_datadir}/pixmaps
%{tde_datadir}/pixmaps/kcmldapbonding_step1.png
%{tde_datadir}/pixmaps/kcmldapbonding_step3.png
+%lang(ru) %{tde_datadir}/locale/ru/LC_MESSAGES/kcmldap.mo
##########
@@ -186,7 +203,7 @@ unset QTDIR QTINC QTLIB
export PATH="%{tde_bindir}:${PATH}"
export PKG_CONFIG_PATH="%{tde_libdir}/pkgconfig"
-if ! rpm -E %%cmake|grep -q "cd build"; then
+if ! rpm -E %%cmake|grep -e 'cd build\|cd ${CMAKE_BUILD_DIR:-build}'; then
%__mkdir_p build
cd build
fi