From e5d408d88409ad03b97fb4e7edda06240c1cb40b Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Sl=C3=A1vek=20Banko?= <slavek.banko@axis.cz>
Date: Sun, 9 May 2021 19:34:05 +0200
Subject: DEB: Add support to build using ninja-build (CMake only) to common
 cdbs rules.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
(cherry picked from commit 36a50c12678c7504007c65da74addaf12e1c2d18)
---
 debian/_base/dependencies/akode/debian/cdbs/debian-tde.mk | 11 ++++++++++-
 1 file changed, 10 insertions(+), 1 deletion(-)

(limited to 'debian/_base/dependencies/akode')

diff --git a/debian/_base/dependencies/akode/debian/cdbs/debian-tde.mk b/debian/_base/dependencies/akode/debian/cdbs/debian-tde.mk
index 5b4e8bfd7..f36e3527c 100644
--- a/debian/_base/dependencies/akode/debian/cdbs/debian-tde.mk
+++ b/debian/_base/dependencies/akode/debian/cdbs/debian-tde.mk
@@ -57,6 +57,15 @@ ifndef _cdbs_class_cmake
 include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
 endif
 
+ifdef _cdbs_class_cmake
+ifneq "$(wildcard /usr/bin/ninja)" ""
+MAKE = ninja -v
+DEB_MAKE_ENVVARS += DESTDIR=$(DEB_DESTDIR)
+DEB_MAKE_INSTALL_TARGET = install
+DEB_CMAKE_NORMAL_ARGS += -GNinja
+endif
+endif
+
 ifndef _cdbs_rules_patchsys_quilt
 DEB_PATCHDIRS := debian/patches/common debian/patches
 endif
@@ -214,7 +223,7 @@ debian/stamp-kde-apidox:
 
 common-install-indep:: common-install-kde-apidox
 common-install-kde-apidox::
-	$(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+	$(if $(DEB_KDE_APIDOX),+DESTDIR=$(DEB_DESTDIR) $(DEB_MAKE_INVOKE) install-apidox)
 
 cleanbuilddir::
 	-$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
-- 
cgit v1.2.1