From 420cce34014bf39356bca01a0ad217107bdafe50 Mon Sep 17 00:00:00 2001
From: Michele Calgaro <michele.calgaro@yahoo.it>
Date: Wed, 18 Mar 2020 12:48:07 +0900
Subject: DEB kstreamripper: switched to cmake.

Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
(cherry picked from commit 0038f7fc68c02e39330101665c3ed9c6c5fe0330)
---
 .../kstreamripper/debian/README.Debian-source      |   8 -
 .../kstreamripper/debian/cdbs/debian-tde.mk        | 218 +++++++++++++++++++++
 .../kstreamripper/debian/cdbs/versions.pl          |  19 ++
 .../applications/kstreamripper/debian/control      |   2 +-
 .../_base/applications/kstreamripper/debian/docs   |   2 +-
 .../debian/kstreamripper-trinity.install           |   1 -
 .../debian/kstreamripper-trinity.menu              |   2 +
 .../kstreamripper/debian/kstreamripper.desktop     |  10 -
 .../kstreamripper/debian/kstreamripper.menu        |   2 -
 .../kstreamripper/debian/patches/.gitignore        |   0
 .../_base/applications/kstreamripper/debian/rules  |  33 ++--
 11 files changed, 254 insertions(+), 43 deletions(-)
 delete mode 100644 debian/_base/applications/kstreamripper/debian/README.Debian-source
 create mode 100644 debian/_base/applications/kstreamripper/debian/cdbs/debian-tde.mk
 create mode 100644 debian/_base/applications/kstreamripper/debian/cdbs/versions.pl
 delete mode 100644 debian/_base/applications/kstreamripper/debian/kstreamripper-trinity.install
 create mode 100644 debian/_base/applications/kstreamripper/debian/kstreamripper-trinity.menu
 delete mode 100644 debian/_base/applications/kstreamripper/debian/kstreamripper.desktop
 delete mode 100644 debian/_base/applications/kstreamripper/debian/kstreamripper.menu
 create mode 100644 debian/_base/applications/kstreamripper/debian/patches/.gitignore

(limited to 'debian')

diff --git a/debian/_base/applications/kstreamripper/debian/README.Debian-source b/debian/_base/applications/kstreamripper/debian/README.Debian-source
deleted file mode 100644
index 57547ac25..000000000
--- a/debian/_base/applications/kstreamripper/debian/README.Debian-source
+++ /dev/null
@@ -1,8 +0,0 @@
-Changes done to the upstream source:
-====================================
-
-Removed:
- ./doc/en/CVS
-
-Also Removed:
- - All python byte compiled files (*.pyc)
diff --git a/debian/_base/applications/kstreamripper/debian/cdbs/debian-tde.mk b/debian/_base/applications/kstreamripper/debian/cdbs/debian-tde.mk
new file mode 100644
index 000000000..7a55130b2
--- /dev/null
+++ b/debian/_base/applications/kstreamripper/debian/cdbs/debian-tde.mk
@@ -0,0 +1,218 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
+# Copyright © 2019 TDE Team
+# Description: A class for TDE packages; sets TDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS   := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
+	cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
+	cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
+	cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
+endif
+	$(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
+	touch debian/stamp-cvs-make
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+ifndef _cdbs_class_cmake
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
+
+ifndef _cdbs_rules_patchsys_quilt
+DEB_PATCHDIRS := debian/patches/common debian/patches
+endif
+
+export kde_cgidir  = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+    cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+    ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+        cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+    else
+        cdbs_kde_enable_final =
+    endif
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+	cdbs_kde_enable_final =
+	cdbs_kde_enable_debug = --enable-debug=yes
+else
+	cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+	cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+DEB_BUILD_PARALLEL ?= true
+
+cdbs_configure_flags += \
+    --with-qt-dir=/usr/share/qt3 \
+    --disable-rpath \
+    --with-xinerama \
+    $(cdbs_kde_enable_final) \
+    $(cdbs_kde_enable_debug)
+
+
+# This is a convenience target for calling manually.
+# It's not part of the build process.
+buildprep: clean apply-patches
+ifndef _cdbs_class_cmake
+	$(MAKE) -f admin/Makefile.common dist
+endif
+	debian/rules clean
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+	if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+	for f in $$(find debian/man -name '*.sgml'); do \
+		docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+	done
+	for f in $$(find debian/man -name '*.man'); do \
+		soelim -I debian/man $$f \
+		> debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+	done
+	touch debian/stamp-man-pages
+
+common-binary-indep::
+	( set -e; \
+	tmpf=`mktemp debian/versions.XXXXXX`; \
+	perl debian/cdbs/versions.pl >$$tmpf; \
+	for p in $(DEB_INDEP_PACKAGES); do \
+	    cat $$tmpf >>debian/$$p.substvars; \
+	done; \
+	rm -f $$tmpf )
+
+common-binary-arch::
+	( set -e; \
+	tmpf=`mktemp debian/versions.XXXXXX`; \
+	perl debian/cdbs/versions.pl >$$tmpf; \
+	for p in $(DEB_ARCH_PACKAGES); do \
+	    cat $$tmpf >>debian/$$p.substvars; \
+	done; \
+	rm -f $$tmpf )
+	# update multi-arch path in install files
+	ls -d debian/* | \
+	grep -E "(install|links)$$" | \
+	while read a; do \
+	    [ -d $$a ] || [ -f $$a.arch ] || \
+	    ! grep -q "\$$(DEB_HOST_MULTIARCH)" $$a || \
+	    sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
+	done
+
+clean::
+	rm -rf debian/man/out
+	-rmdir debian/man
+	rm -f debian/stamp-man-pages
+	rm -rf debian/shlibs-check
+	# revert multi-arch path in install files
+	ls -d debian/* | \
+	grep -E "(install|links)$$" | \
+	while read a; do \
+	    [ ! -f $$a.arch ] || \
+	    mv $$a.arch $$a; \
+	done
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+	if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+	if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+	if test -e debian/$(cdbs_curpkg).lintian; then \
+		install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+			debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+	fi
+	if test -e debian/$(cdbs_curpkg).presubj; then \
+		install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+			debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+	fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+	set -e; \
+	for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+		pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+		echo Building $$pkg HTML docs...; \
+		mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+		cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+		/opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+	done
+	for pkg in $(DOC_HTML_PRUNE) ; do \
+	  rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+	done
+
+common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+	$(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+	touch $@
+
+common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+	$(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) install-apidox DESTDIR=$(DEB_DESTDIR))
+
+cleanbuilddir::
+	-$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+clean::
+ifndef _cdbs_class_cmake
+	if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+		cd $(DEB_SRCDIR); \
+		find . -name Makefile.in -print | \
+			xargs --no-run-if-empty rm -f; \
+		rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+			configure configure.files configure.in stamp-h.in \
+			subdirs; \
+	fi
+endif
+	rm -f debian/stamp-kde-apidox
+	rm -f debian/stamp-cvs-make
+
+endif
diff --git a/debian/_base/applications/kstreamripper/debian/cdbs/versions.pl b/debian/_base/applications/kstreamripper/debian/cdbs/versions.pl
new file mode 100644
index 000000000..1b110f7af
--- /dev/null
+++ b/debian/_base/applications/kstreamripper/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version)  =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "TDE-Version3=$version3\n";
+print "TDE-Version2=$version2\n";
+print "TDE-Next-Version3=$version3_next\n";
+print "TDE-Next-Version2=$version2_next\n";
diff --git a/debian/_base/applications/kstreamripper/debian/control b/debian/_base/applications/kstreamripper/debian/control
index 677544f2a..8a6590104 100644
--- a/debian/_base/applications/kstreamripper/debian/control
+++ b/debian/_base/applications/kstreamripper/debian/control
@@ -2,7 +2,7 @@ Source: kstreamripper-trinity
 Section: sound 
 Priority: optional
 Maintainer: Michael Ablassmeier <abi@debian.org>
-Build-Depends: debhelper (>= 9~), cdbs, libxmu-dev, libjpeg-dev, tdelibs14-trinity-dev, scons
+Build-Depends: debhelper (>= 9~), cdbs, tdelibs14-trinity-dev, cmake, quilt
 Standards-Version: 3.8.4
 
 Package: kstreamripper-trinity
diff --git a/debian/_base/applications/kstreamripper/debian/docs b/debian/_base/applications/kstreamripper/debian/docs
index 724e08449..6f12db508 100644
--- a/debian/_base/applications/kstreamripper/debian/docs
+++ b/debian/_base/applications/kstreamripper/debian/docs
@@ -1,2 +1,2 @@
+AUTHORS
 README
-TODO
diff --git a/debian/_base/applications/kstreamripper/debian/kstreamripper-trinity.install b/debian/_base/applications/kstreamripper/debian/kstreamripper-trinity.install
deleted file mode 100644
index dc292dbda..000000000
--- a/debian/_base/applications/kstreamripper/debian/kstreamripper-trinity.install
+++ /dev/null
@@ -1 +0,0 @@
-debian/kstreamripper.desktop opt/trinity/share/applications
diff --git a/debian/_base/applications/kstreamripper/debian/kstreamripper-trinity.menu b/debian/_base/applications/kstreamripper/debian/kstreamripper-trinity.menu
new file mode 100644
index 000000000..f2cfe85c6
--- /dev/null
+++ b/debian/_base/applications/kstreamripper/debian/kstreamripper-trinity.menu
@@ -0,0 +1,2 @@
+?package(kstreamripper-trinity): needs="X11" section="Apps/Sound" title="Kstreamripper" \
+  longtitle="Streamripper Frontend" command="/opt/trinity/bin/kstreamripper" 
diff --git a/debian/_base/applications/kstreamripper/debian/kstreamripper.desktop b/debian/_base/applications/kstreamripper/debian/kstreamripper.desktop
deleted file mode 100644
index a0c155fac..000000000
--- a/debian/_base/applications/kstreamripper/debian/kstreamripper.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Encoding=UTF-8
-Name=KStreamRipper
-Comment=Streamripper Frontend
-Exec=kstreamripper
-Icon=kstreamripper
-Type=Application
-Terminal=false
-Categories=AudioVideo;Audio;Tuner;Recorder;
diff --git a/debian/_base/applications/kstreamripper/debian/kstreamripper.menu b/debian/_base/applications/kstreamripper/debian/kstreamripper.menu
deleted file mode 100644
index f2cfe85c6..000000000
--- a/debian/_base/applications/kstreamripper/debian/kstreamripper.menu
+++ /dev/null
@@ -1,2 +0,0 @@
-?package(kstreamripper-trinity): needs="X11" section="Apps/Sound" title="Kstreamripper" \
-  longtitle="Streamripper Frontend" command="/opt/trinity/bin/kstreamripper" 
diff --git a/debian/_base/applications/kstreamripper/debian/patches/.gitignore b/debian/_base/applications/kstreamripper/debian/patches/.gitignore
new file mode 100644
index 000000000..e69de29bb
diff --git a/debian/_base/applications/kstreamripper/debian/rules b/debian/_base/applications/kstreamripper/debian/rules
index 88540f9bf..18aa16b96 100755
--- a/debian/_base/applications/kstreamripper/debian/rules
+++ b/debian/_base/applications/kstreamripper/debian/rules
@@ -1,26 +1,19 @@
 #!/usr/bin/make -f
+
 include /usr/share/cdbs/1/rules/debhelper.mk
-#DEB_INSTALL_MANPAGES_kstreamripper-trinity:=debian/kstreamripper.1
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-tde.mk
 
 DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
                                && echo xz || echo bzip2)
 
-PATH := /opt/trinity/bin:$(PATH)
-
-build/kstreamripper-trinity::
-	env PATH=/opt/trinity/bin:$(PATH) QTDIR=/usr/share/tqt3 $(MAKE)
-
-install/kstreamripper-trinity::
-	env PATH=/opt/trinity/bin:$(PATH) QTDIR=/usr/share/tqt3 DESTDIR=$(DEB_DESTDIR) $(MAKE) install
-	mkdir -p $(DEB_DESTDIR)/opt/trinity/share/pixmaps/
-	mkdir -p $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/
-	install -m 644 ./src/hi32-app-kstreamripper.png \
-		$(DEB_DESTDIR)/opt/trinity/share/pixmaps/kstreamripper.png
-	rm -rf $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML
-	rm -rf $(DEB_DESTDIR)/usr
-
-clean::
-	-$(MAKE) clean	
-	rm -f scons_signatures.dblite
-	rm -f *.pyc admin/*.pyc
-	rm -rf cache/
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"
-- 
cgit v1.2.1