From bd72eef4a4458f8d2e52609d7b6cf3efe12a0177 Mon Sep 17 00:00:00 2001
From: Michele Calgaro <michele.calgaro@yahoo.it>
Date: Sun, 4 Jul 2021 21:06:02 +0900
Subject: Rearranged applications folder into sub categories.

Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
---
 .../twin-style-suse2/debian/cdbs/debian-tde.mk     | 246 ---------------------
 .../twin-style-suse2/debian/cdbs/versions.pl       |  19 --
 .../applications/twin-style-suse2/debian/changelog |  43 ----
 .../applications/twin-style-suse2/debian/compat    |   1 -
 .../applications/twin-style-suse2/debian/control   |  18 --
 .../applications/twin-style-suse2/debian/copyright |  57 -----
 .../twin-style-suse2/debian/patches/series         |   0
 .../applications/twin-style-suse2/debian/rules     |  17 --
 .../twin-style-suse2/debian/source/format          |   1 -
 .../twin-style-suse2/debian/source/options         |   6 -
 10 files changed, 408 deletions(-)
 delete mode 100644 ubuntu/_base/applications/twin-style-suse2/debian/cdbs/debian-tde.mk
 delete mode 100644 ubuntu/_base/applications/twin-style-suse2/debian/cdbs/versions.pl
 delete mode 100644 ubuntu/_base/applications/twin-style-suse2/debian/changelog
 delete mode 100644 ubuntu/_base/applications/twin-style-suse2/debian/compat
 delete mode 100644 ubuntu/_base/applications/twin-style-suse2/debian/control
 delete mode 100644 ubuntu/_base/applications/twin-style-suse2/debian/copyright
 delete mode 100644 ubuntu/_base/applications/twin-style-suse2/debian/patches/series
 delete mode 100755 ubuntu/_base/applications/twin-style-suse2/debian/rules
 delete mode 100644 ubuntu/_base/applications/twin-style-suse2/debian/source/format
 delete mode 100644 ubuntu/_base/applications/twin-style-suse2/debian/source/options

(limited to 'ubuntu/_base/applications/twin-style-suse2/debian')

diff --git a/ubuntu/_base/applications/twin-style-suse2/debian/cdbs/debian-tde.mk b/ubuntu/_base/applications/twin-style-suse2/debian/cdbs/debian-tde.mk
deleted file mode 100644
index f36e3527c..000000000
--- a/ubuntu/_base/applications/twin-style-suse2/debian/cdbs/debian-tde.mk
+++ /dev/null
@@ -1,246 +0,0 @@
-# -*- mode: makefile; coding: utf-8 -*-
-# Copyright © 2003 Christopher L Cheney <ccheney@debian.org>
-# Copyright © 2019 TDE Team
-# Description: A class for TDE packages; sets TDE environment variables, etc
-#
-# This program is free software; you can redistribute it and/or
-# modify it under the terms of the GNU General Public License as
-# published by the Free Software Foundation; either version 2, or (at
-# your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
-# 02111-1307 USA.
-
-ifndef _cdbs_bootstrap
-_cdbs_scripts_path ?= /usr/lib/cdbs
-_cdbs_rules_path ?= /usr/share/cdbs/1/rules
-_cdbs_class_path ?= /usr/share/cdbs/1/class
-endif
-
-ifndef _cdbs_class_debian-qt-kde
-_cdbs_class_debian-qt-kde := 1
-
-# for dh_icons
-CDBS_BUILD_DEPENDS   := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
-
-# Note: This _must_ be included before autotools.mk, or it won't work.
-common-configure-arch common-configure-indep:: debian/stamp-cvs-make
-debian/stamp-cvs-make:
-ifndef _cdbs_class_cmake
-	cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
-ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
-	cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
-endif
-ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
-	cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
-endif
-	$(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
-endif
-	touch debian/stamp-cvs-make
-
-include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
-
-ifdef _cdbs_tarball_dir
-DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
-else
-DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
-endif
-
-ifndef _cdbs_class_cmake
-include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
-endif
-
-ifdef _cdbs_class_cmake
-ifneq "$(wildcard /usr/bin/ninja)" ""
-MAKE = ninja -v
-DEB_MAKE_ENVVARS += DESTDIR=$(DEB_DESTDIR)
-DEB_MAKE_INSTALL_TARGET = install
-DEB_CMAKE_NORMAL_ARGS += -GNinja
-endif
-endif
-
-ifndef _cdbs_rules_patchsys_quilt
-DEB_PATCHDIRS := debian/patches/common debian/patches
-endif
-
-export kde_cgidir  = \$${libdir}/cgi-bin
-export kde_confdir = \$${sysconfdir}/trinity
-export kde_htmldir = \$${datadir}/doc/tde/HTML
-
-DEB_KDE_ENABLE_FINAL := yes
-DEB_INSTALL_DOCS_ALL :=
-
-DEB_DH_MAKESHLIBS_ARGS_ALL := -V
-DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
-
-DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
-DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
-DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
-
-# The default gzip compressor has been changed in dpkg >= 1.17.0.
-deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
-                         sed -e "s|.*version ||" -e "s| .*||" | \
-                         xargs -r dpkg --compare-versions 1.17.0 lt \
-                         && echo xz || echo gzip)
-ifeq ($(deb_default_compress),gzip)
-DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
-                               && echo xz || echo bzip2)
-endif
-
-ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-    cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
-    ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
-        cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
-    else
-        cdbs_kde_enable_final =
-    endif
-endif
-
-ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
-	cdbs_kde_enable_final =
-	cdbs_kde_enable_debug = --enable-debug=yes
-else
-	cdbs_kde_enable_debug = --disable-debug
-endif
-
-ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
-	cdbs_kde_enable_debug = --enable-debug=full
-endif
-
-DEB_BUILD_PARALLEL ?= true
-
-cdbs_configure_flags += \
-    --with-qt-dir=/usr/share/qt3 \
-    --disable-rpath \
-    --with-xinerama \
-    $(cdbs_kde_enable_final) \
-    $(cdbs_kde_enable_debug)
-
-
-# This is a convenience target for calling manually.
-# It's not part of the build process.
-buildprep: clean apply-patches
-ifndef _cdbs_class_cmake
-	$(MAKE) -f admin/Makefile.common dist
-endif
-	debian/rules clean
-
-.tdepkginfo:
-	echo "# TDE package information" >.tdepkginfo
-	dpkg-parsechangelog | sed -n "s|^Source: |Name: |p" >>.tdepkginfo
-	dpkg-parsechangelog | sed -n "s|^Version: |Version: |p" >>.tdepkginfo
-	date +"DateTime: %m/%d/%Y %H:%M" -u -d "$$(dpkg-parsechangelog | sed -n 's|^Date: ||p')" >>.tdepkginfo
-
-post-patches:: .tdepkginfo
-
-common-build-arch:: debian/stamp-man-pages
-debian/stamp-man-pages:
-	if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
-	for f in $$(find debian/man -name '*.sgml'); do \
-		docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
-	done
-	for f in $$(find debian/man -name '*.man'); do \
-		soelim -I debian/man $$f \
-		> debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
-	done
-	touch debian/stamp-man-pages
-
-common-binary-indep::
-	( set -e; \
-	tmpf=`mktemp debian/versions.XXXXXX`; \
-	perl debian/cdbs/versions.pl >$$tmpf; \
-	for p in $(DEB_INDEP_PACKAGES); do \
-	    cat $$tmpf >>debian/$$p.substvars; \
-	done; \
-	rm -f $$tmpf )
-
-common-binary-arch::
-	( set -e; \
-	tmpf=`mktemp debian/versions.XXXXXX`; \
-	perl debian/cdbs/versions.pl >$$tmpf; \
-	for p in $(DEB_ARCH_PACKAGES); do \
-	    cat $$tmpf >>debian/$$p.substvars; \
-	done; \
-	rm -f $$tmpf )
-	# update multi-arch path in install files
-	ls -d debian/* | \
-	grep -E "(install|links)$$" | \
-	while read a; do \
-	    [ -d $$a ] || [ -f $$a.arch ] || \
-	    ! grep -q "\$$(DEB_HOST_MULTIARCH)" $$a || \
-	    sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
-	done
-
-clean::
-	rm -rf debian/man/out
-	-rmdir debian/man
-	rm -f debian/stamp-man-pages
-	rm -rf debian/shlibs-check
-	# revert multi-arch path in install files
-	ls -d debian/* | \
-	grep -E "(install|links)$$" | \
-	while read a; do \
-	    [ ! -f $$a.arch ] || \
-	    mv $$a.arch $$a; \
-	done
-
-$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
-	if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
-	if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
-	if test -e debian/$(cdbs_curpkg).lintian; then \
-		install -p -D -m644 debian/$(cdbs_curpkg).lintian \
-			debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
-	fi
-	if test -e debian/$(cdbs_curpkg).presubj; then \
-		install -p -D -m644 debian/$(cdbs_curpkg).presubj \
-			debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
-	fi
-
-binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
-	set -e; \
-	for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
-		pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
-		echo Building $$pkg HTML docs...; \
-		mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
-		cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
-		/opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
-	done
-	for pkg in $(DOC_HTML_PRUNE) ; do \
-	  rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
-	done
-
-common-build-indep:: debian/stamp-kde-apidox
-debian/stamp-kde-apidox:
-	$(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
-	touch $@
-
-common-install-indep:: common-install-kde-apidox
-common-install-kde-apidox::
-	$(if $(DEB_KDE_APIDOX),+DESTDIR=$(DEB_DESTDIR) $(DEB_MAKE_INVOKE) install-apidox)
-
-cleanbuilddir::
-	-$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
-
-clean::
-ifndef _cdbs_class_cmake
-	if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
-		cd $(DEB_SRCDIR); \
-		find . -name Makefile.in -print | \
-			xargs --no-run-if-empty rm -f; \
-		rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
-			configure configure.files configure.in stamp-h.in \
-			subdirs; \
-	fi
-endif
-	rm -f .tdepkginfo
-	rm -f debian/stamp-kde-apidox
-	rm -f debian/stamp-cvs-make
-
-endif
diff --git a/ubuntu/_base/applications/twin-style-suse2/debian/cdbs/versions.pl b/ubuntu/_base/applications/twin-style-suse2/debian/cdbs/versions.pl
deleted file mode 100644
index 1b110f7af..000000000
--- a/ubuntu/_base/applications/twin-style-suse2/debian/cdbs/versions.pl
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/usr/bin/env perl
-
-use strict;
-use warnings;
-
-my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
-my ($version3, $version3_next);
-my ($version2, $version2_next);
-
-($version3 = $version)  =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
-($version2 = $version3) =~ s/\.[^.]+$//;
-
-($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
-($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
-
-print "TDE-Version3=$version3\n";
-print "TDE-Version2=$version2\n";
-print "TDE-Next-Version3=$version3_next\n";
-print "TDE-Next-Version2=$version2_next\n";
diff --git a/ubuntu/_base/applications/twin-style-suse2/debian/changelog b/ubuntu/_base/applications/twin-style-suse2/debian/changelog
deleted file mode 100644
index be5feccc1..000000000
--- a/ubuntu/_base/applications/twin-style-suse2/debian/changelog
+++ /dev/null
@@ -1,43 +0,0 @@
-twin-style-suse2-trinity (0.4.1-1) unstable; urgency=low
-
-  * Initial release for TDE
-
- -- Mavridis Philippe <mavridisf@gmail.com>  Sat, 26 Jun 2021 11:07:15 +0900
-
-twin-decor-suse2 (0.4.1-1) unstable; urgency=low
-
-  * Updated to 0.4.1
-
- -- Gerd Fleischer <gerdfleischer@web.de>  Sat, 17 Jun 2007 19:56:34 +0200
-
-twin-decor-suse2 (0.4-1) unstable; urgency=low
-
-  * Updated to 0.4
-
- -- Gerd Fleischer <gerdfleischer@web.de>  Thu, 02 Nov 2006 19:56:34 +0200
-
-twin-decor-suse2 (0.3.5-1) unstable; urgency=low
-
-  * Updated to 0.3.5
-
- -- Gerd Fleischer <gerdfleischer@web.de>  Sat, 20 May 2006 19:56:34 +0200
-
-twin-decor-suse2 (0.3.4-1) unstable; urgency=low
-
-  * Updated to 0.3.4
-
- -- Gerd Fleischer <gerdfleischer@web.de>  Thu, 23 Feb 2006 19:56:34 +0200
-
-twin-decor-suse2 (0.3.2-1) unstable; urgency=low
-
-  * Updated to 0.3.2
-  * renamed to twin-style-suse2 to match debian naming rules
-  * replaces older twin-decor-suse2 named packages
-
- -- Gerd Fleischer <gerdfleischer@web.de>  Thu, 08 Dec 2005 19:56:34 +0200
-
-twin-decor-suse2 (0.3.1-1) unstable; urgency=low
-
-  * Updated to 0.3.1
-
- -- Gerd Fleischer <gerdfleischer@web.de>  Mon, 19 Sep 2005 19:56:34 +0200
diff --git a/ubuntu/_base/applications/twin-style-suse2/debian/compat b/ubuntu/_base/applications/twin-style-suse2/debian/compat
deleted file mode 100644
index ec635144f..000000000
--- a/ubuntu/_base/applications/twin-style-suse2/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-9
diff --git a/ubuntu/_base/applications/twin-style-suse2/debian/control b/ubuntu/_base/applications/twin-style-suse2/debian/control
deleted file mode 100644
index 52c1269a5..000000000
--- a/ubuntu/_base/applications/twin-style-suse2/debian/control
+++ /dev/null
@@ -1,18 +0,0 @@
-Source: twin-style-suse2-trinity
-Section: tde
-Priority: optional
-Maintainer: TDE Debian Team <team-debian@trinitydesktop.org>
-XSBC-Original-Maintainer: Adrian Neumaier <adrian@firehand.org>
-Build-Depends: cdbs, debhelper (>= 9~), quilt, cmake-trinity, ninja-build, tdelibs-trinity-dev, tdebase-trinity-dev
-Standards-Version: 3.6.2
-
-Package: twin-style-suse2-trinity
-Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}
-Description: TDE window decoration from SUSE 9.3
- This is a port of the SUSE 9.3 KDE Window decoration extracted from SUSE.
- .
- It features in additon to the original theme several new button
- styles and a changeable titlebar image.
- .
- A color scheme for TDE is provided too.
diff --git a/ubuntu/_base/applications/twin-style-suse2/debian/copyright b/ubuntu/_base/applications/twin-style-suse2/debian/copyright
deleted file mode 100644
index d5f625f8d..000000000
--- a/ubuntu/_base/applications/twin-style-suse2/debian/copyright
+++ /dev/null
@@ -1,57 +0,0 @@
-This package was debianized by Adrian Neumaier <adrian@firehand.org> on
-Mon, 19 Sep 2005 19:56:34 +0200
-
-It was downloaded from http://www.gerdfleischer.de/twin-decor-suse2/
-
-Authors: Adrian Schroeter <adrian@suse.de>
-	 Gerd Fleischer <gerdfleischer@web.de>
-	 Sandro Giessl <ceebx@users.sourceforge.net>
-	 Rik Hemsley (rikkus) <rik@kde.org>
-	 Laur Ivan <laurivan@eircom.net>
-
-Copyright: 2005, Adrian Schroeter
-	   2003, Sandro Giessl
-	   2001, Rik Hemsley
-	   2005, Gerd Fleischer
-	   2003, Laur Ivan
-
-License:
-
-For the files shadow.cpp and shadow.h the following license applies:
-
-   This library is free software; you can redistribute it and/or
-   modify it under the terms of the GNU Library General Public
-   License version 2 as published by the Free Software Foundation.
-
-   This library is distributed in the hope that it will be useful,
-   but WITHOUT ANY WARRANTY; without even the implied warranty of
-   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
-   Library General Public License for more details.
-
-   You should have received a copy of the GNU Library General Public License
-   along with this library; see the file COPYING.LIB.  If not, write to the 
-   Free Software Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA
-   02111-1301, USA.
-
-On Debian systems, the complete text of the GNU Library General Public
-License can be found in `/usr/share/common-licenses/LGPL'.
-
-For the rest of the package this license applies:
-
-   This package is free software; you can redistribute it and/or modify
-   it under the terms of the GNU General Public License as published by
-   the Free Software Foundation; version 2 dated June, 1991.
-
-   This package is distributed in the hope that it will be useful,
-   but WITHOUT ANY WARRANTY; without even the implied warranty of
-   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-   GNU General Public License for more details.
-
-   You should have received a copy of the GNU General Public License
-   along with this package; if not, write to the Free Software
-   Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA
-   02111-1301, USA.
-
-On Debian systems, the complete text of the GNU General
-Public License can be found in `/usr/share/common-licenses/GPL'.
-
diff --git a/ubuntu/_base/applications/twin-style-suse2/debian/patches/series b/ubuntu/_base/applications/twin-style-suse2/debian/patches/series
deleted file mode 100644
index e69de29bb..000000000
diff --git a/ubuntu/_base/applications/twin-style-suse2/debian/rules b/ubuntu/_base/applications/twin-style-suse2/debian/rules
deleted file mode 100755
index a6797f19a..000000000
--- a/ubuntu/_base/applications/twin-style-suse2/debian/rules
+++ /dev/null
@@ -1,17 +0,0 @@
-#!/usr/bin/make -f
-
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/cmake.mk
-include debian/cdbs/debian-tde.mk
-
-DEB_CMAKE_EXTRA_FLAGS := \
- -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
- -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
- -DCONFIG_INSTALL_DIR="/etc/trinity" \
- -DSYSCONF_INSTALL_DIR="/etc/trinity" \
- -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_VERBOSE_MAKEFILE="ON" \
- -DCMAKE_SKIP_RPATH="OFF" \
- -DBUILD_ALL="ON" \
- -DWITH_ALL_OPTIONS="ON"
diff --git a/ubuntu/_base/applications/twin-style-suse2/debian/source/format b/ubuntu/_base/applications/twin-style-suse2/debian/source/format
deleted file mode 100644
index 163aaf8d8..000000000
--- a/ubuntu/_base/applications/twin-style-suse2/debian/source/format
+++ /dev/null
@@ -1 +0,0 @@
-3.0 (quilt)
diff --git a/ubuntu/_base/applications/twin-style-suse2/debian/source/options b/ubuntu/_base/applications/twin-style-suse2/debian/source/options
deleted file mode 100644
index 72f1f5450..000000000
--- a/ubuntu/_base/applications/twin-style-suse2/debian/source/options
+++ /dev/null
@@ -1,6 +0,0 @@
-# Use xz instead of gzip
-compression = "xz"
-compression-level = 9
-
-# Don't run differences
-diff-ignore = .*
-- 
cgit v1.2.1