summaryrefslogtreecommitdiffstats
path: root/client/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2024-03-23 12:36:06 +0900
committerMavridis Philippe <[email protected]>2024-03-24 23:17:06 +0200
commit341a38ba101216f8b544cc653416d6e2e6b6d34e (patch)
tree6b519900aaedb621fae20842152e86c745c2b688 /client/CMakeLists.txt
parentfd62635a2792b5cbbbae1c5288992af0054332ee (diff)
downloadtde-style-polyester-341a38ba101216f8b544cc653416d6e2e6b6d34e.tar.gz
tde-style-polyester-341a38ba101216f8b544cc653416d6e2e6b6d34e.zip
1. Replace inkscape with rsvg-convert (this idea comes from a patch in the original debian packaging files).
2. All png images and the associated `button.h` file are generate at build time. 3. Make `create-buttons.sh` work for out-of-source builds. Signed-off-by: Michele Calgaro <[email protected]>
Diffstat (limited to 'client/CMakeLists.txt')
-rw-r--r--client/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
index 07fb701..903baf5 100644
--- a/client/CMakeLists.txt
+++ b/client/CMakeLists.txt
@@ -21,6 +21,16 @@ link_directories(
tde_import(twin)
+
+### buttons.h ##################################################################
+
+configure_file( create-buttons.sh.cmake create-buttons.sh @ONLY )
+
+add_custom_target( buttons.h
+ COMMAND ${CMAKE_COMMAND} -E env ${CMAKE_CURRENT_BINARY_DIR}/create-buttons.sh
+)
+
+
### twin_polyester (kpart) #####################################################
tde_add_kpart( twin_polyester AUTOMOC
@@ -38,6 +48,9 @@ tde_add_kpart( twin_polyester AUTOMOC
DESTINATION ${PLUGIN_INSTALL_DIR}
)
+add_dependencies( twin_polyester-module buttons.h )
+
+
### other data #################################################################
install(
@@ -45,6 +58,7 @@ install(
DESTINATION ${DATA_INSTALL_DIR}/twin
)
+
### configuration module #######################################################
add_subdirectory(config)