summaryrefslogtreecommitdiffstats
path: root/style/CMakeLists.txt
diff options
context:
space:
mode:
authorMavridis Philippe <[email protected]>2024-03-10 19:48:49 +0200
committerMavridis Philippe <[email protected]>2024-03-10 20:04:10 +0200
commitbf8023245ca81129b27778d9e38f4cbdcdd1dc5b (patch)
tree9d87daf1597b81e8e0f0eb493f0c1f2930627822 /style/CMakeLists.txt
parentff13ed1771d5265ffc9e2d70945dd990c6b93289 (diff)
downloadtde-style-polyester-bf8023245ca81129b27778d9e38f4cbdcdd1dc5b.tar.gz
tde-style-polyester-bf8023245ca81129b27778d9e38f4cbdcdd1dc5b.zip
Port to CMake build system
Signed-off-by: Mavridis Philippe <[email protected]>
Diffstat (limited to 'style/CMakeLists.txt')
-rw-r--r--style/CMakeLists.txt43
1 files changed, 43 insertions, 0 deletions
diff --git a/style/CMakeLists.txt b/style/CMakeLists.txt
new file mode 100644
index 0000000..8087699
--- /dev/null
+++ b/style/CMakeLists.txt
@@ -0,0 +1,43 @@
+################################################################################
+# Polyester - widget style and twin decoration aimed to be a good balance #
+# between eye candy and simplicity #
+# #
+# This file is released under the GNU GPL version 3 or later. #
+# Improvements and feedback are welcome! #
+################################################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIBRARY_DIRS}
+)
+
+### polyester (kpart) ##########################################################
+tde_add_kpart(polyester
+ AUTOMOC
+
+ SOURCES
+ polyester.cpp
+ misc.cpp
+
+ LINK
+ tdecore-shared
+
+ DESTINATION ${PLUGIN_INSTALL_DIR}/plugins/styles
+)
+
+### configuration module #######################################################
+add_subdirectory(config)
+
+### other data #################################################################
+install(
+ FILES polyester.themerc
+ DESTINATION ${DATA_INSTALL_DIR}/tdestyle/themes
+) \ No newline at end of file