summaryrefslogtreecommitdiffstats
path: root/style/Makefile.am
diff options
context:
space:
mode:
authorMavridis Philippe <[email protected]>2024-03-10 17:53:54 +0200
committerMavridis Philippe <[email protected]>2024-03-10 17:53:54 +0200
commit7f408ad635a5e2a7829db68c19e51a295d55b9d1 (patch)
treea494c34a4c7a10d114a6b95fc4216f3eabce4e81 /style/Makefile.am
downloadtde-style-polyester-7f408ad635a5e2a7829db68c19e51a295d55b9d1.tar.gz
tde-style-polyester-7f408ad635a5e2a7829db68c19e51a295d55b9d1.zip
Imported from Pling
Diffstat (limited to 'style/Makefile.am')
-rwxr-xr-xstyle/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/style/Makefile.am b/style/Makefile.am
new file mode 100755
index 0000000..47292a3
--- /dev/null
+++ b/style/Makefile.am
@@ -0,0 +1,21 @@
+AUTOMAKE_OPTIONS = foreign
+
+SUBDIRS = config
+
+KDE_CXXFLAGS = -DQT_PLUGIN
+
+METASOURCES = AUTO
+
+INCLUDES = $(all_includes)
+
+stylercdir = $(kde_datadir)/kstyle/themes
+stylerc_DATA = polyester.themerc
+
+EXTRA_DIST = $(stylerc_DATA)
+
+noinst_HEADERS = polyester.h misc.h
+
+kde_style_LTLIBRARIES = polyester.la
+polyester_la_SOURCES = polyester.cpp misc.cpp
+polyester_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN) -module
+polyester_la_LIBADD = -lkdefx