summaryrefslogtreecommitdiffstats
path: root/client/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
new file mode 100644
index 0000000..5b779ba
--- /dev/null
+++ b/client/Makefile.am
@@ -0,0 +1,19 @@
+AUTOMAKE_OPTIONS = foreign
+
+SUBDIRS = config images
+
+KDE_CXXFLAGS = -DQT_PLUGIN
+
+METASOURCES = AUTO
+
+INCLUDES = $(all_includes) -I$(kde_includes)/kwin
+
+kwindir = $(kde_datadir)/kwin/
+kwin_DATA = polyester.desktop
+
+noinst_HEADERS = polyester.h buttons.h shadow.h ../style/misc.h
+
+kde_module_LTLIBRARIES = kwin3_polyester.la
+kwin3_polyester_la_SOURCES = polyester.cc shadow.cpp ../style/misc.cpp
+kwin3_polyester_la_LIBADD = $(kde_libraries)/libkdecorations.la
+kwin3_polyester_la_LDFLAGS = -module $(all_libraries) $(KDE_PLUGIN) -lkdecore