summaryrefslogtreecommitdiffstats
path: root/style/config/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'style/config/CMakeLists.txt')
-rw-r--r--style/config/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/style/config/CMakeLists.txt b/style/config/CMakeLists.txt
new file mode 100644
index 0000000..095f5a6
--- /dev/null
+++ b/style/config/CMakeLists.txt
@@ -0,0 +1,31 @@
+################################################################################
+# Polyester - widget style and twin decoration aimed to be a good balance #
+# between eye candy and simplicity #
+# #
+# This file is released under the GNU GPL version 3 or later. #
+# Improvements and feedback are welcome! #
+################################################################################
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+ ${TDE_LIBRARY_DIRS}
+)
+
+### tdestyle_polyester_config (kpart) ##########################################
+tde_add_kpart(tdestyle_polyester_config
+ AUTOMOC
+
+ SOURCES
+ configdialog.ui
+ polyesterconf.cpp
+
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+) \ No newline at end of file