summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-08-15 16:06:28 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-08-15 16:06:28 +0200
commitbf3bc777f02fe90d6d377d4e47f914bfc83cd86a (patch)
tree5fc67f858ed370d97316895f028f9ef91832b36f /CMakeLists.txt
parent679214ce9a37406c4930dd265c2438baa2a31405 (diff)
downloadtde-systemsettings-bf3bc777f02fe90d6d377d4e47f914bfc83cd86a.tar.gz
tde-systemsettings-bf3bc777f02fe90d6d377d4e47f914bfc83cd86a.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 782caae..57828fe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,8 +69,12 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( systemsettings )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+
+
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
##### write configure files