summaryrefslogtreecommitdiffstats
path: root/kate/scripts/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2020-07-15 20:12:47 +0200
committerSlávek Banko <[email protected]>2020-07-15 20:12:47 +0200
commitcb8cda7bca532df21c02bc4d2bfd03387df7f852 (patch)
tree7f6b988c304024c9a45bccc2070790b65b95553e /kate/scripts/CMakeLists.txt
parent41f27d91571102626d9aae843adbe070fcb5aef3 (diff)
downloadtdeaddons-cb8cda7bca532df21c02bc4d2bfd03387df7f852.tar.gz
tdeaddons-cb8cda7bca532df21c02bc4d2bfd03387df7f852.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'kate/scripts/CMakeLists.txt')
-rw-r--r--kate/scripts/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/kate/scripts/CMakeLists.txt b/kate/scripts/CMakeLists.txt
index 0cbb2b8..3584e06 100644
--- a/kate/scripts/CMakeLists.txt
+++ b/kate/scripts/CMakeLists.txt
@@ -1,5 +1,11 @@
-# This file is genereted by trinity-automake-cmake-convert script by Fat-Zer
-install( FILES html-tidy.desktop html-tidy.sh
+install(
+ FILES html-tidy.sh
DESTINATION ${DATA_INSTALL_DIR}/kate/scripts
)
+
+tde_create_translated_desktop(
+ SOURCE html-tidy.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/kate/scripts
+ PO_DIR kate-plugins-desktops
+)