summaryrefslogtreecommitdiffstats
path: root/konq-plugins/akregator/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2020-07-15 20:12:47 +0200
committerSlávek Banko <[email protected]>2020-07-15 20:12:47 +0200
commitcb8cda7bca532df21c02bc4d2bfd03387df7f852 (patch)
tree7f6b988c304024c9a45bccc2070790b65b95553e /konq-plugins/akregator/CMakeLists.txt
parent41f27d91571102626d9aae843adbe070fcb5aef3 (diff)
downloadtdeaddons-cb8cda7bca532df21c02bc4d2bfd03387df7f852.tar.gz
tdeaddons-cb8cda7bca532df21c02bc4d2bfd03387df7f852.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'konq-plugins/akregator/CMakeLists.txt')
-rw-r--r--konq-plugins/akregator/CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/konq-plugins/akregator/CMakeLists.txt b/konq-plugins/akregator/CMakeLists.txt
index acddd2d..d938b51 100644
--- a/konq-plugins/akregator/CMakeLists.txt
+++ b/konq-plugins/akregator/CMakeLists.txt
@@ -33,7 +33,14 @@ tde_add_kpart( libakregatorkonqfeedicon AUTOMOC
##### other data ################################
-install( FILES akregator_konqfeedicon.desktop akregator_konqfeedicon.rc
+tde_create_translated_desktop(
+ SOURCE akregator_konqfeedicon.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/tdehtml/kpartplugins
+ PO_DIR konq-plugins-desktops
+)
+
+install(
+ FILES akregator_konqfeedicon.rc
DESTINATION ${DATA_INSTALL_DIR}/tdehtml/kpartplugins
)
@@ -41,6 +48,8 @@ install( FILES rss.png
DESTINATION ${DATA_INSTALL_DIR}/akregator/pics
)
-install( FILES akregator_konqplugin.desktop
+tde_create_translated_desktop(
+ SOURCE akregator_konqplugin.desktop
DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR konq-plugins-desktops
)