summaryrefslogtreecommitdiffstats
path: root/konq-plugins/akregator/Makefile.am
diff options
context:
space:
mode:
authortoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
committertoma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2009-11-25 17:56:58 +0000
commit84da08d7b7fcda12c85caeb5a10b4903770a6f69 (patch)
tree2a6aea76f2dfffb4cc04bb907c4725af94f70e72 /konq-plugins/akregator/Makefile.am
downloadtdeaddons-84da08d7b7fcda12c85caeb5a10b4903770a6f69.tar.gz
tdeaddons-84da08d7b7fcda12c85caeb5a10b4903770a6f69.zip
Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
BUG:215923 git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdeaddons@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'konq-plugins/akregator/Makefile.am')
-rw-r--r--konq-plugins/akregator/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/konq-plugins/akregator/Makefile.am b/konq-plugins/akregator/Makefile.am
new file mode 100644
index 0000000..c6964d1
--- /dev/null
+++ b/konq-plugins/akregator/Makefile.am
@@ -0,0 +1,25 @@
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+
+
+# Install this plugin in the KDE modules directory
+kde_module_LTLIBRARIES = libakregatorkonqplugin.la libakregatorkonqfeedicon.la
+
+libakregatorkonqplugin_la_SOURCES = akregatorplugin.cpp pluginbase.cpp
+libakregatorkonqplugin_la_LIBADD = -lkonq $(LIB_KHTML)
+libakregatorkonqplugin_la_LDFLAGS = -module $(KDE_PLUGIN) -avoid-version -no-undefined $(all_libraries)
+
+libakregatorkonqfeedicon_la_SOURCES = konqfeedicon.cpp feeddetector.cpp pluginbase.cpp
+libakregatorkonqfeedicon_la_LIBADD = -lkonq $(LIB_KHTML)
+libakregatorkonqfeedicon_la_LDFLAGS = -module $(KDE_PLUGIN) -avoid-version -no-undefined $(all_libraries)
+
+konqplugindir = $(kde_servicesdir)
+konqplugin_DATA = akregator_konqplugin.desktop
+konqfeedicondir = $(kde_datadir)/khtml/kpartplugins
+konqfeedicon_DATA = akregator_konqfeedicon.desktop akregator_konqfeedicon.rc
+
+rssicondir = $(kde_datadir)/akregator/pics
+rssicon_DATA = rss.png
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/akregator_konqplugin.pot