summaryrefslogtreecommitdiffstats
path: root/kaddressbook-plugins/xxports/gmx/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kaddressbook-plugins/xxports/gmx/Makefile.am')
-rw-r--r--kaddressbook-plugins/xxports/gmx/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/kaddressbook-plugins/xxports/gmx/Makefile.am b/kaddressbook-plugins/xxports/gmx/Makefile.am
new file mode 100644
index 0000000..facdd37
--- /dev/null
+++ b/kaddressbook-plugins/xxports/gmx/Makefile.am
@@ -0,0 +1,18 @@
+INCLUDES = $(all_includes)
+
+kde_module_LTLIBRARIES = libkaddrbk_gmx_xxport.la
+
+servicedir = $(kde_servicesdir)/kaddressbook
+service_DATA = gmx_xxport.desktop
+
+libkaddrbk_gmx_xxport_la_SOURCES = gmx_xxport.cpp
+libkaddrbk_gmx_xxport_la_LDFLAGS = -module $(KDE_PLUGIN) $(KDE_RPATH) $(all_libraries) -no-undefined
+libkaddrbk_gmx_xxport_la_LIBADD = $(LIB_KDEUI) -lkabc -lkabinterfaces
+libkaddrbk_gmx_xxport_la_METASOURCES = AUTO
+
+rc_DATA = gmx_xxportui.rc
+rcdir = $(kde_datadir)/kaddressbook
+
+messages: rc.cpp
+ $(XGETTEXT) *.cpp *.h -o $(podir)/libkaddrbk_gmx_xxport.pot
+