From 84da08d7b7fcda12c85caeb5a10b4903770a6f69 Mon Sep 17 00:00:00 2001
From: toma <toma@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>
Date: Wed, 25 Nov 2009 17:56:58 +0000
Subject: Copy the KDE 3.5 branch to branches/trinity for new KDE 3.5 features.
 BUG:215923

git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/kdeaddons@1054174 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
---
 kfile-plugins/desktop/Makefile.am | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
 create mode 100644 kfile-plugins/desktop/Makefile.am

(limited to 'kfile-plugins/desktop/Makefile.am')

diff --git a/kfile-plugins/desktop/Makefile.am b/kfile-plugins/desktop/Makefile.am
new file mode 100644
index 0000000..4fdfa7f
--- /dev/null
+++ b/kfile-plugins/desktop/Makefile.am
@@ -0,0 +1,22 @@
+## Makefile.am for .desktop file meta info plugin
+
+# set the include path for X, qt and KDE
+INCLUDES         = $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS   = kfile_desktop.h
+
+kde_module_LTLIBRARIES = kfile_desktop.la
+
+kfile_desktop_la_SOURCES = kfile_desktop.cpp
+kfile_desktop_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN)
+kfile_desktop_la_LIBADD = $(LIB_KIO)
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+messages:
+	$(XGETTEXT) *.cpp -o $(podir)/kfile_desktop.pot
+
+services_DATA = kfile_desktop.desktop
+servicesdir = $(kde_servicesdir)
-- 
cgit v1.2.1