summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2024-03-15 11:18:50 +0900
committerMichele Calgaro <[email protected]>2024-03-15 23:53:45 +0900
commit917de3261d9fcf83235ab5c4fd257bcfdd2d83cf (patch)
tree1e67f6baf0fc920962eed214ad1c7771d65e373d /CMakeLists.txt
parentaecd11b5aeaeec251b531c29dcd3db38d3d868de (diff)
downloadtdeartwork-917de3261d9fcf83235ab5c4fd257bcfdd2d83cf.tar.gz
tdeartwork-917de3261d9fcf83235ab5c4fd257bcfdd2d83cf.zip
Use centralized cmake version
Signed-off-by: Michele Calgaro <[email protected]> (cherry picked from commit e12682f818cc04d9de9cfc87ca9a39db6b3127e1)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ecfe8be7..2801b501 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,7 +9,12 @@
# #
###########################################
-cmake_minimum_required( VERSION 3.5 )
+
+##### set project version ########################
+
+include( TDEVersion )
+cmake_minimum_required( VERSION ${TDE_CMAKE_MINIMUM_VERSION} )
+tde_set_project_version( )
##### general package setup
@@ -33,11 +38,6 @@ include( CheckSymbolExists )
include( TDEMacros )
-##### set version number ########################
-
-tde_set_project_version( )
-
-
##### setup install paths
include( TDESetupPaths )