summaryrefslogtreecommitdiffstats
path: root/kcontrol/tdefontinst/viewpart/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2020-06-28 00:42:21 +0200
committerSlávek Banko <[email protected]>2020-06-28 00:42:21 +0200
commit92841ae8b62560f0b137dc838bfd12ac78d26599 (patch)
tree77ff1aee27f10b9ba54d6c6e1f4d972c72d69b67 /kcontrol/tdefontinst/viewpart/CMakeLists.txt
parent191cf4812dfa7524f32916423d79f072d88f56d1 (diff)
downloadtdebase-92841ae8b62560f0b137dc838bfd12ac78d26599.tar.gz
tdebase-92841ae8b62560f0b137dc838bfd12ac78d26599.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 2f706891f32258c2b070471905f983e4585296d2)
Diffstat (limited to 'kcontrol/tdefontinst/viewpart/CMakeLists.txt')
-rw-r--r--kcontrol/tdefontinst/viewpart/CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/kcontrol/tdefontinst/viewpart/CMakeLists.txt b/kcontrol/tdefontinst/viewpart/CMakeLists.txt
index 5dd3ddc63..7aa960dda 100644
--- a/kcontrol/tdefontinst/viewpart/CMakeLists.txt
+++ b/kcontrol/tdefontinst/viewpart/CMakeLists.txt
@@ -24,8 +24,17 @@ link_directories(
##### other data ################################
-install( FILES tdefontviewpart.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
-install( FILES tdefontview.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE tdefontviewpart.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR kcontrol-desktops
+)
+
+tde_create_translated_desktop(
+ SOURCE tdefontview.desktop
+ PO_DIR kcontrol-desktops
+)
+
install( FILES tdefontviewpart.rc tdefontviewui.rc DESTINATION ${DATA_INSTALL_DIR}/tdefontview )