summaryrefslogtreecommitdiffstats
path: root/kdesktop/CMakeLists.txt
diff options
context:
space:
mode:
authorEmanoil Kotsev <[email protected]>2025-01-23 22:01:36 +0000
committerEmanoil Kotsev <[email protected]>2025-01-23 22:01:36 +0000
commitdb4ed0e58e77c469239cc339d0e7949868a3321b (patch)
treed4c81f82bd1d845c0769834e3501e685cdbf2fca /kdesktop/CMakeLists.txt
parent80c8c1aaf8c3b7be34be80dfe59610a0a765a204 (diff)
downloadtdebase-db4ed0e58e77c469239cc339d0e7949868a3321b.tar.gz
tdebase-db4ed0e58e77c469239cc339d0e7949868a3321b.zip
fixing wrongly reverted pthread in kdesktop/CMakeLists.txt
remove WORKING_DIRECTORY in add_custom_command in kdesktop/dbus/interfaces/CMakeLists.txt Signed-off-by: Emanoil Kotsev <[email protected]>
Diffstat (limited to 'kdesktop/CMakeLists.txt')
-rw-r--r--kdesktop/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/kdesktop/CMakeLists.txt b/kdesktop/CMakeLists.txt
index 906eee4cc..0e564e0fe 100644
--- a/kdesktop/CMakeLists.txt
+++ b/kdesktop/CMakeLists.txt
@@ -99,7 +99,7 @@ set( ${target}_SRCS
tde_add_tdeinit_executable( ${target} AUTOMOC
SOURCES ${${target}_SRCS}
LINK
- pthread kdesktopsettings-static bgnd-static dmctl-static
+ ${CMAKE_THREAD_LIBS_INIT} kdesktopsettings-static bgnd-static dmctl-static
dbusscreensaverservice-static dbusscreensaveriface-static
konq-shared tdeutils-shared tdesu-shared ${TDEHW_LIBRARIES}
${XRENDER_LIBRARIES} ${XCURSOR_LIBRARIES} Xext ${CMAKE_DL_LIBS}