summaryrefslogtreecommitdiffstats
path: root/kfind/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2020-06-26 11:36:35 +0200
committerSlávek Banko <[email protected]>2020-06-28 00:41:12 +0200
commit2f706891f32258c2b070471905f983e4585296d2 (patch)
tree6c74e28fd7c74d26b1c36c371a9ed56295cc05ae /kfind/CMakeLists.txt
parent98f2d732f33659ba749b70fb939e8eaa0c97edf8 (diff)
downloadtdebase-2f706891f32258c2b070471905f983e4585296d2.tar.gz
tdebase-2f706891f32258c2b070471905f983e4585296d2.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'kfind/CMakeLists.txt')
-rw-r--r--kfind/CMakeLists.txt17
1 files changed, 14 insertions, 3 deletions
diff --git a/kfind/CMakeLists.txt b/kfind/CMakeLists.txt
index 4162c1319..aceaa738b 100644
--- a/kfind/CMakeLists.txt
+++ b/kfind/CMakeLists.txt
@@ -30,9 +30,20 @@ link_directories(
##### other data ################################
tde_install_icons( kfind )
-install( FILES Kfind.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
-install( FILES kfindpart.desktop DESTINATION ${SERVICES_INSTALL_DIR} )
-install( FILES findpart.desktop DESTINATION ${SERVICETYPES_INSTALL_DIR} )
+tde_create_translated_desktop(
+ SOURCE Kfind.desktop
+ PO_DIR kfind-desktops
+)
+tde_create_translated_desktop(
+ SOURCE kfindpart.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+ PO_DIR kfind-desktops
+)
+tde_create_translated_desktop(
+ SOURCE findpart.desktop
+ DESTINATION ${SERVICETYPES_INSTALL_DIR}
+ PO_DIR kfind-desktops
+)
##### libkfindpart (module) #####################