summaryrefslogtreecommitdiffstats
path: root/khotkeys/app/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2024-09-19 17:48:43 +0900
committerMichele Calgaro <[email protected]>2024-09-20 20:06:45 +0900
commit94368f4722fa8eae1f7e7cd4b02679a760b0d620 (patch)
tree4fdf1f3f6250211c2ab47dc568e299ea4e139c3c /khotkeys/app/CMakeLists.txt
parent7f1a1e931e73b53939ca39faca82c80cf5da5cf4 (diff)
downloadtdebase-94368f4722fa8eae1f7e7cd4b02679a760b0d620.tar.gz
tdebase-94368f4722fa8eae1f7e7cd4b02679a760b0d620.zip
Various fixes for khotkeys. This resolves issue #326.
1. ensure there is a single khotkeys instance running per session instead of per screen (remote multihead related code) 2. allow khotkeys to be run as a kded module 3. make sure that khotkeys run either as a standalone application or as a kded module, but not both at the same time 4. do not register khotkeys as a main DCOP entry (like an app) anymore. When run as kded module, this was causing kded to be registered as khotkeys a second time. Signed-off-by: Michele Calgaro <[email protected]>
Diffstat (limited to 'khotkeys/app/CMakeLists.txt')
-rw-r--r--khotkeys/app/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/khotkeys/app/CMakeLists.txt b/khotkeys/app/CMakeLists.txt
index df2bd70db..470fdf1ce 100644
--- a/khotkeys/app/CMakeLists.txt
+++ b/khotkeys/app/CMakeLists.txt
@@ -22,6 +22,14 @@ link_directories(
)
+##### other data ################################
+
+tde_create_translated_desktop(
+ SOURCE khotkeys.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}/kded
+)
+
+
##### kded_khotkeys (module) ####################
tde_add_kpart( kded_khotkeys AUTOMOC