summaryrefslogtreecommitdiffstats
path: root/ksmserver/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <[email protected]>2024-11-03 11:04:08 +0900
committerMichele Calgaro <[email protected]>2024-11-03 11:31:40 +0900
commitd5ec3d83b6eeaf5b7c4e2b02f231f7091a13f222 (patch)
tree40f4fb1ee1a172fc172cee2c8dd5a866aa064dcf /ksmserver/CMakeLists.txt
parentba767a247d8152600535005da253cf8f0c750b44 (diff)
downloadtdebase-d5ec3d83b6eeaf5b7c4e2b02f231f7091a13f222.tar.gz
tdebase-d5ec3d83b6eeaf5b7c4e2b02f231f7091a13f222.zip
Remove unnecessary code related to the simple login modal dialog.fix/issue-314
The showFancyLogin option controls the appearance of a simple modal dialog at login. This dialog is disabled if a splash screen is used. The dialog would show up if: 1. no splash screen was used and a new unsaved session was started 2. the 'Unified' splash screen was used and a saved session was restored. In this case the dialog and the 'Unified' splash screen would both be shown, covering each other. This is a partial revert of commit b971f9aae7 and resolves issue #314. Signed-off-by: Michele Calgaro <[email protected]>
Diffstat (limited to 'ksmserver/CMakeLists.txt')
-rw-r--r--ksmserver/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/ksmserver/CMakeLists.txt b/ksmserver/CMakeLists.txt
index aa6681f28..c8ffea812 100644
--- a/ksmserver/CMakeLists.txt
+++ b/ksmserver/CMakeLists.txt
@@ -44,7 +44,7 @@ install( FILES move_session_config.sh DESTINATION ${KCONF_UPDATE_INSTALL_DIR} )
tde_add_tdeinit_executable( ksmserver AUTOMOC
SOURCES
- main.cpp server.cpp shutdowndlg.cpp startupdlg.cpp
+ main.cpp server.cpp shutdowndlg.cpp
legacy.cpp startup.cpp shutdown.cpp client.cpp
KSMServerInterface.skel server.skel timed.ui
LINK dmctl-static tdeui-shared tdersync-shared ${TDEHW_LIBRARIES}