summaryrefslogtreecommitdiffstats
path: root/l10n/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2020-06-28 00:42:21 +0200
committerSlávek Banko <[email protected]>2020-06-28 00:42:21 +0200
commit92841ae8b62560f0b137dc838bfd12ac78d26599 (patch)
tree77ff1aee27f10b9ba54d6c6e1f4d972c72d69b67 /l10n/CMakeLists.txt
parent191cf4812dfa7524f32916423d79f072d88f56d1 (diff)
downloadtdebase-92841ae8b62560f0b137dc838bfd12ac78d26599.tar.gz
tdebase-92841ae8b62560f0b137dc838bfd12ac78d26599.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 2f706891f32258c2b070471905f983e4585296d2)
Diffstat (limited to 'l10n/CMakeLists.txt')
-rw-r--r--l10n/CMakeLists.txt26
1 files changed, 18 insertions, 8 deletions
diff --git a/l10n/CMakeLists.txt b/l10n/CMakeLists.txt
index c9516b52c..96c9eb5b5 100644
--- a/l10n/CMakeLists.txt
+++ b/l10n/CMakeLists.txt
@@ -7,7 +7,8 @@
#
#################################################
-install( FILES
+tde_create_translated_desktop(
+ SOURCE
northafrica.desktop westafrica.desktop southafrica.desktop
centralafrica.desktop caribbean.desktop oceania.desktop
centralamerica.desktop northamerica.desktop southamerica.desktop
@@ -15,16 +16,25 @@ install( FILES
northeurope.desktop southeurope.desktop southasia.desktop
southeastasia.desktop eastasia.desktop centralasia.desktop
middleeast.desktop
- DESTINATION
- ${LOCALE_INSTALL_DIR}/l10n )
+ DESTINATION ${LOCALE_INSTALL_DIR}/l10n
+ PO_DIR l10n-desktops
+)
file( GLOB _dirs RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} * )
foreach( _dir ${_dirs} )
- if( IS_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/${_dir} )
- if( NOT (${_dir} STREQUAL ".svn" OR ${_dir} STREQUAL "CMakeFiles") )
- install( FILES ${_dir}/entry.desktop ${_dir}/flag.png
- DESTINATION ${LOCALE_INSTALL_DIR}/l10n/${_dir} )
- endif( )
+ if( IS_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/${_dir} AND
+ NOT (${_dir} STREQUAL ".svn" OR ${_dir} STREQUAL "CMakeFiles") AND
+ EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/${_dir}/entry.desktop AND
+ EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/${_dir}/flag.png )
+ tde_create_translated_desktop(
+ SOURCE ${_dir}/entry.desktop
+ DESTINATION ${LOCALE_INSTALL_DIR}/l10n/${_dir}
+ PO_DIR l10n-desktops
+ )
+ install(
+ FILES ${_dir}/flag.png
+ DESTINATION ${LOCALE_INSTALL_DIR}/l10n/${_dir}
+ )
endif( )
endforeach( )