summaryrefslogtreecommitdiffstats
path: root/tdeioslave/home/Makefile.am
diff options
context:
space:
mode:
authorTimothy Pearson <[email protected]>2013-01-27 01:02:02 -0600
committerTimothy Pearson <[email protected]>2013-01-27 01:02:02 -0600
commitde7e5867a65e0a46f1388e3e50bc7eeddd1aecbf (patch)
treedbb3152c372f8620f9290137d461f3d9f9eba1cb /tdeioslave/home/Makefile.am
parent936d3cec490c13f2c5f7dd14f5e364fddaa6da71 (diff)
downloadtdebase-de7e5867a65e0a46f1388e3e50bc7eeddd1aecbf.tar.gz
tdebase-de7e5867a65e0a46f1388e3e50bc7eeddd1aecbf.zip
Rename a number of libraries and executables to avoid conflicts with KDE4
Diffstat (limited to 'tdeioslave/home/Makefile.am')
-rw-r--r--tdeioslave/home/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/tdeioslave/home/Makefile.am b/tdeioslave/home/Makefile.am
new file mode 100644
index 000000000..38b73e653
--- /dev/null
+++ b/tdeioslave/home/Makefile.am
@@ -0,0 +1,32 @@
+SUBDIRS= . kdedmodule
+# wizard
+
+INCLUDES = $(all_includes)
+METASOURCES = AUTO
+
+kde_module_LTLIBRARIES = kio_home.la
+
+kio_home_la_SOURCES = dummy.cpp
+kio_home_la_LIBADD = libtdeiohome.la $(LIB_KIO)
+kio_home_la_LDFLAGS = $(all_libraries) -module $(KDE_PLUGIN) -no-undefined
+
+dummy.cpp:
+ echo > dummy.cpp
+
+kde_services_DATA = home.protocol
+
+noinst_LTLIBRARIES = libtdeiohome.la
+libtdeiohome_la_SOURCES = kio_home.cpp homeimpl.cpp
+
+check_PROGRAMS = testhome
+testhome_SOURCES = testhome.cpp
+testhome_LDADD = libtdeiohome.la $(LIB_KIO)
+testhome_LDFLAGS = $(all_libraries)
+
+## TODO in unsermake: TESTS = testhome
+check: testhome
+ ./testhome
+
+messages:
+ $(XGETTEXT) `find . -name "*.cc" -o -name "*.cpp" -o -name "*.h"` -o $(podir)/tdeio_home.pot
+