summaryrefslogtreecommitdiffstats
path: root/tdm/backend/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2024-04-15 02:56:07 +0200
committerSlávek Banko <[email protected]>2024-04-15 03:17:42 +0200
commitc2268515a1c7a3107286d0a56f3ccda60527e4d0 (patch)
treef22c35f81dde85194ce78de2b415143f5ea40ed4 /tdm/backend/CMakeLists.txt
parentb151ca953f1282dc59b83a42a4e010643458cf61 (diff)
downloadtdebase-c2268515a1c7a3107286d0a56f3ccda60527e4d0.tar.gz
tdebase-c2268515a1c7a3107286d0a56f3ccda60527e4d0.zip
tdm: Allow to detect pthread_setname_np. Add linking pthread.
This relates to issue #473. Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 28a2ef7c5f28dea8ce9b5d2f14b366ada0353e0c)
Diffstat (limited to 'tdm/backend/CMakeLists.txt')
-rw-r--r--tdm/backend/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tdm/backend/CMakeLists.txt b/tdm/backend/CMakeLists.txt
index f09704486..cb0cd3d3f 100644
--- a/tdm/backend/CMakeLists.txt
+++ b/tdm/backend/CMakeLists.txt
@@ -49,6 +49,6 @@ tde_add_executable( tdm
process.c protodpy.c reset.c resource.c rpcauth.c
server.c session.c sessreg.c socket.c streams.c
util.c xdmauth.c xdmcp.c
- LINK X11 ${XAU_LIBRARIES} ${DBUS_LIBRARIES} ${CRYPT_LIBRARY} ${PAM_LIBRARY} ${UTIL_LIBRARY} ${XDMCP_LIBRARIES}
+ LINK X11 pthread ${XAU_LIBRARIES} ${DBUS_LIBRARIES} ${CRYPT_LIBRARY} ${PAM_LIBRARY} ${UTIL_LIBRARY} ${XDMCP_LIBRARIES}
DESTINATION ${BIN_INSTALL_DIR}
)