summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 4 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c1b7e79bd..42f8d341c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -71,9 +71,8 @@ option( WITH_XCURSOR "Enable xcursor support" ${WITH_ALL_OPTIONS} )
option( WITH_XFIXES "Enable xfixes support" ${WITH_ALL_OPTIONS} )
option( WITH_XRANDR "Enable xrandr support" ${WITH_ALL_OPTIONS} )
option( WITH_XRENDER "Enable xrender support" ${WITH_ALL_OPTIONS} )
-option( WITH_XDAMAGE "Enable xdamage support" ${WITH_ALL_OPTIONS} )
-option( WITH_XEXT "Enable xext support" ${WITH_ALL_OPTIONS} )
option( WITH_LIBCONFIG "Enable libconfig support" ${WITH_ALL_OPTIONS} )
+option( WITH_PCRE "Enable pcre regex support" ON )
option( WITH_XTEST "Enable xtest support" ${WITH_ALL_OPTIONS} )
option( WITH_OPENGL "Enable openGL support" ${WITH_ALL_OPTIONS} )
option( WITH_XSCREENSAVER "Enable xscreensaver support" ${WITH_ALL_OPTIONS} )
@@ -104,8 +103,6 @@ option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden"
# WITH_XCOMPOSITE affects twin kicker(taskmanager) tdm
# WITH_XCURSOR affects tdeioslaves(thumbnail), kcontrol(input), kdesktop
# WITH_XFIXES affects twin klipper kicker(taskmanager)
-# WITH_XDAMAGE affects <nothing>
-# WITH_XEXT affects <nothing>
# WITH_XRANDR affects tdm, kcontrol(displayconfig randr iccconfig)
# WITH_XRENDER affects twin konsole kicker(taskmanager) kdesktop
# kcontrol(style)
@@ -118,7 +115,7 @@ option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden"
# WITH_LIBART affects tdm kcontrol(icons background)
# WITH_LIBUSB affects kcontrol(input)
# WITH_XDMCP affects tdm
-# WITH_XINERAMA affects ksplashml
+# WITH_XINERAMA affects ksplashml twin/compton-tde
# WITH_ARTS affects libkonq khotkeys
# WITH_I8K affects ksysguard
# WITH_SENSORS affects ksysguard
@@ -128,6 +125,8 @@ option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden"
# WITH_PAM affects tdm kdesktop kcheckpass
# WITH_SHADOW affects tdm kcheckpass
# WITH_UPOWER affects ksmserver
+# WITH_LIBCONFIG affects twin/compot-tde
+# WITH_PCRE affects twin/compot-tde
# WITH_SUDO_TDESU_BACKEND affects tdesu
# WITH_SUDO_KONSOLE_SUPER_USER_COMMAND affects launching Konsole super user sessions
@@ -136,10 +135,6 @@ option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden"
# NOTE: if WITH_XCOMPOSITE=ON then the following options are also required:
# WITH_XRENDER=ON
# WITH_XFIXES=ON
-# WITH_XDAMAGE=ON
-# WITH_XEXT=ON
-# NOTE: seems WITH_XDAMAGE and WITH_XET doesn't change anything
-# they are just required by WITH_XCOMPOSITE
##### user requested modules ####################