summaryrefslogtreecommitdiffstats
path: root/kcontrol/kdm/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'kcontrol/kdm/CMakeLists.txt')
-rw-r--r--kcontrol/kdm/CMakeLists.txt40
1 files changed, 0 insertions, 40 deletions
diff --git a/kcontrol/kdm/CMakeLists.txt b/kcontrol/kdm/CMakeLists.txt
deleted file mode 100644
index 004282250..000000000
--- a/kcontrol/kdm/CMakeLists.txt
+++ /dev/null
@@ -1,40 +0,0 @@
-#################################################
-#
-# (C) 2010-2011 Serghei Amelian
-# serghei (DOT) amelian (AT) gmail.com
-#
-# Improvements and feedback are welcome
-#
-# This file is released under GPL >= 2
-#
-#################################################
-
-include_directories(
- ${CMAKE_CURRENT_BINARY_DIR}
- ${CMAKE_BINARY_DIR}/kcontrol/background
- ${CMAKE_BINARY_DIR}
- ${TDE_INCLUDE_DIR}
- ${TQT_INCLUDE_DIRS}
-)
-
-link_directories(
- ${TQT_LIBRARY_DIRS}
-)
-
-##### other data ################################
-
-install( FILES tdm.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )
-
-
-##### kcm_tdm (module) ##########################
-
-set_source_files_properties( background.cpp PROPERTIES COMPILE_FLAGS -DKDE_CONFDIR=\\"${TDE_CONFIG_DIR}\\" )
-set_source_files_properties( main.cpp PROPERTIES COMPILE_FLAGS -DKDE_CONFDIR=\\"${TDE_CONFIG_DIR}\\" )
-
-tde_add_kpart( kcm_tdm AUTOMOC
- SOURCES
- background.cpp tdm-appear.cpp tdm-font.cpp tdm-shut.cpp
- tdm-users.cpp tdm-conv.cpp main.cpp kbackedcombobox.cpp
- LINK kcmbgnd-static bgnd-static knewstuff-shared
- DESTINATION ${PLUGIN_INSTALL_DIR}
-)