summaryrefslogtreecommitdiffstats
path: root/ktip/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ktip/Makefile.am')
-rw-r--r--ktip/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/ktip/Makefile.am b/ktip/Makefile.am
new file mode 100644
index 000000000..6bcd39991
--- /dev/null
+++ b/ktip/Makefile.am
@@ -0,0 +1,29 @@
+INCLUDES = $(all_includes)
+
+SUBDIRS = pics
+
+bin_PROGRAMS = ktip
+ktip_SOURCES = ktipwindow.cpp
+ktip_LDADD = $(LIB_TDEUI)
+ktip_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_QT) -lDCOP $(LIB_TDECORE) $(LIB_TDEUI) -ltdefx $(LIB_TDEIO) -ltdetexteditor
+
+METASOURCES = AUTO
+KDE_ICON = AUTO
+
+xdg_apps_DATA = ktip.desktop
+
+autostart_DATA = ktip.desktop
+autostartdir = $(datadir)/autostart
+
+install-data-local: uninstall.desktop
+ $(mkinstalldirs) $(DESTDIR)$(kde_appsdir)/Toys
+ $(INSTALL_DATA) $(srcdir)/uninstall.desktop $(DESTDIR)$(kde_appsdir)/Toys/ktip.desktop
+
+messages:
+ $(PREPARETIPS) > tips.txt
+ $(XGETTEXT) *.txt *.cpp -o $(podir)/ktip.pot
+ rm -f tips.txt
+
+appdata_DATA = tips
+appdatadir=$(kde_datadir)/tdewizard
+