summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorEmanoil Kotsev <[email protected]>2018-11-12 21:18:37 +0100
committerEmanoil Kotsev <[email protected]>2023-01-14 03:44:08 +0000
commite274309d9293777aaaecebccaa29a339a05bd4f9 (patch)
treea00349c31b90cdedaa6e351dfe93950b55903dce /debian
parent63c233987977aa48b701edeb47079a6153359fbe (diff)
downloadtdebluez-e274309d9293777aaaecebccaa29a339a05bd4f9.tar.gz
tdebluez-e274309d9293777aaaecebccaa29a339a05bd4f9.zip
Based on KDE3 bluez4 version a TDE bluez5 version was created
Signed-off-by: Emanoil Kotsev <[email protected]>
Diffstat (limited to 'debian')
-rw-r--r--debian/cdbs/debian-tde.mk246
-rw-r--r--debian/cdbs/versions.pl19
-rw-r--r--debian/changelog12
-rw-r--r--debian/compat1
-rw-r--r--debian/control70
-rw-r--r--debian/copyright43
-rw-r--r--debian/docs1
-rw-r--r--debian/libtdebluez-dev.install2
-rw-r--r--debian/libtdebluez.install5
-rw-r--r--debian/libtdeobex-dev.install2
-rw-r--r--debian/libtdeobex.install4
-rwxr-xr-xdebian/rules17
-rw-r--r--debian/source/format1
-rw-r--r--debian/source/options6
-rw-r--r--debian/tdeblueplugd62
-rw-r--r--debian/tdeblueplugd.desktop42
-rw-r--r--debian/tdebluez.install24
-rw-r--r--debian/tdebluez.preinst32
-rw-r--r--debian/watch9
19 files changed, 598 insertions, 0 deletions
diff --git a/debian/cdbs/debian-tde.mk b/debian/cdbs/debian-tde.mk
new file mode 100644
index 0000000..f36e352
--- /dev/null
+++ b/debian/cdbs/debian-tde.mk
@@ -0,0 +1,246 @@
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2003 Christopher L Cheney <[email protected]>
+# Copyright © 2019 TDE Team
+# Description: A class for TDE packages; sets TDE environment variables, etc
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; either version 2, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA
+# 02111-1307 USA.
+
+ifndef _cdbs_bootstrap
+_cdbs_scripts_path ?= /usr/lib/cdbs
+_cdbs_rules_path ?= /usr/share/cdbs/1/rules
+_cdbs_class_path ?= /usr/share/cdbs/1/class
+endif
+
+ifndef _cdbs_class_debian-qt-kde
+_cdbs_class_debian-qt-kde := 1
+
+# for dh_icons
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), debhelper (>= 5.0.7ubuntu4)
+
+# Note: This _must_ be included before autotools.mk, or it won't work.
+common-configure-arch common-configure-indep:: debian/stamp-cvs-make
+debian/stamp-cvs-make:
+ifndef _cdbs_class_cmake
+ cp -Rp /usr/share/aclocal/libtool.m4 admin/libtool.m4.in
+ifneq "$(wildcard /usr/share/libtool/config/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/config/ltmain.sh admin/ltmain.sh
+endif
+ifneq "$(wildcard /usr/share/libtool/build-aux/ltmain.sh)" ""
+ cp -Rp /usr/share/libtool/build-aux/ltmain.sh admin/ltmain.sh
+endif
+ $(MAKE) -C $(DEB_SRCDIR) -f admin/Makefile.common dist;
+endif
+ touch debian/stamp-cvs-make
+
+include $(_cdbs_rules_path)/buildcore.mk$(_cdbs_makefile_suffix)
+
+ifdef _cdbs_tarball_dir
+DEB_BUILDDIR = $(_cdbs_tarball_dir)/obj-$(DEB_BUILD_GNU_TYPE)
+else
+DEB_BUILDDIR = obj-$(DEB_BUILD_GNU_TYPE)
+endif
+
+ifndef _cdbs_class_cmake
+include $(_cdbs_class_path)/autotools.mk$(_cdbs_makefile_suffix)
+endif
+
+ifdef _cdbs_class_cmake
+ifneq "$(wildcard /usr/bin/ninja)" ""
+MAKE = ninja -v
+DEB_MAKE_ENVVARS += DESTDIR=$(DEB_DESTDIR)
+DEB_MAKE_INSTALL_TARGET = install
+DEB_CMAKE_NORMAL_ARGS += -GNinja
+endif
+endif
+
+ifndef _cdbs_rules_patchsys_quilt
+DEB_PATCHDIRS := debian/patches/common debian/patches
+endif
+
+export kde_cgidir = \$${libdir}/cgi-bin
+export kde_confdir = \$${sysconfdir}/trinity
+export kde_htmldir = \$${datadir}/doc/tde/HTML
+
+DEB_KDE_ENABLE_FINAL := yes
+DEB_INSTALL_DOCS_ALL :=
+
+DEB_DH_MAKESHLIBS_ARGS_ALL := -V
+DEB_SHLIBDEPS_INCLUDE = $(foreach p,$(PACKAGES_WITH_LIBS),debian/$(p)/usr/lib)
+
+DEB_AC_AUX_DIR = $(DEB_SRCDIR)/admin
+DEB_CONFIGURE_INCLUDEDIR = "\$${prefix}/include"
+DEB_COMPRESS_EXCLUDE = .dcl .docbook -license .tag .sty .el
+
+# The default gzip compressor has been changed in dpkg >= 1.17.0.
+deb_default_compress = $(shell LANG=C dpkg-deb --version | head -n1 | \
+ sed -e "s|.*version ||" -e "s| .*||" | \
+ xargs -r dpkg --compare-versions 1.17.0 lt \
+ && echo xz || echo gzip)
+ifeq ($(deb_default_compress),gzip)
+DEB_DH_BUILDDEB_ARGS += -- -Z$(shell dpkg-deb --help | grep -q ":.* xz[,.]" \
+ && echo xz || echo bzip2)
+endif
+
+ifeq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ cdbs_treat_me_gently_arches := arm m68k alpha ppc64 armel armeb
+ ifeq (,$(filter $(DEB_HOST_ARCH_CPU),$(cdbs_treat_me_gently_arches)))
+ cdbs_kde_enable_final = $(if $(DEB_KDE_ENABLE_FINAL),--enable-final,)
+ else
+ cdbs_kde_enable_final =
+ endif
+endif
+
+ifneq (,$(filter nostrip,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_final =
+ cdbs_kde_enable_debug = --enable-debug=yes
+else
+ cdbs_kde_enable_debug = --disable-debug
+endif
+
+ifneq (,$(filter debug,$(DEB_BUILD_OPTIONS)))
+ cdbs_kde_enable_debug = --enable-debug=full
+endif
+
+DEB_BUILD_PARALLEL ?= true
+
+cdbs_configure_flags += \
+ --with-qt-dir=/usr/share/qt3 \
+ --disable-rpath \
+ --with-xinerama \
+ $(cdbs_kde_enable_final) \
+ $(cdbs_kde_enable_debug)
+
+
+# This is a convenience target for calling manually.
+# It's not part of the build process.
+buildprep: clean apply-patches
+ifndef _cdbs_class_cmake
+ $(MAKE) -f admin/Makefile.common dist
+endif
+ debian/rules clean
+
+.tdepkginfo:
+ echo "# TDE package information" >.tdepkginfo
+ dpkg-parsechangelog | sed -n "s|^Source: |Name: |p" >>.tdepkginfo
+ dpkg-parsechangelog | sed -n "s|^Version: |Version: |p" >>.tdepkginfo
+ date +"DateTime: %m/%d/%Y %H:%M" -u -d "$$(dpkg-parsechangelog | sed -n 's|^Date: ||p')" >>.tdepkginfo
+
+post-patches:: .tdepkginfo
+
+common-build-arch:: debian/stamp-man-pages
+debian/stamp-man-pages:
+ if ! test -d debian/man/out; then mkdir -p debian/man/out; fi
+ for f in $$(find debian/man -name '*.sgml'); do \
+ docbook-to-man $$f > debian/man/out/`basename $$f .sgml`.1; \
+ done
+ for f in $$(find debian/man -name '*.man'); do \
+ soelim -I debian/man $$f \
+ > debian/man/out/`basename $$f .man`.`head -n1 $$f | awk '{print $$NF}'`; \
+ done
+ touch debian/stamp-man-pages
+
+common-binary-indep::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_INDEP_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+
+common-binary-arch::
+ ( set -e; \
+ tmpf=`mktemp debian/versions.XXXXXX`; \
+ perl debian/cdbs/versions.pl >$$tmpf; \
+ for p in $(DEB_ARCH_PACKAGES); do \
+ cat $$tmpf >>debian/$$p.substvars; \
+ done; \
+ rm -f $$tmpf )
+ # update multi-arch path in install files
+ ls -d debian/* | \
+ grep -E "(install|links)$$" | \
+ while read a; do \
+ [ -d $$a ] || [ -f $$a.arch ] || \
+ ! grep -q "\$$(DEB_HOST_MULTIARCH)" $$a || \
+ sed -i.arch "s|\$$(DEB_HOST_MULTIARCH)|$(DEB_HOST_MULTIARCH)|g" $$a; \
+ done
+
+clean::
+ rm -rf debian/man/out
+ -rmdir debian/man
+ rm -f debian/stamp-man-pages
+ rm -rf debian/shlibs-check
+ # revert multi-arch path in install files
+ ls -d debian/* | \
+ grep -E "(install|links)$$" | \
+ while read a; do \
+ [ ! -f $$a.arch ] || \
+ mv $$a.arch $$a; \
+ done
+
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+ if test -x /usr/bin/dh_icons; then dh_icons -p$(cdbs_curpkg) $(DEB_DH_ICONCACHE_ARGS); fi
+ if test -x /usr/bin/dh_desktop; then dh_desktop -p$(cdbs_curpkg) $(DEB_DH_DESKTOP_ARGS); fi
+ if test -e debian/$(cdbs_curpkg).lintian; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).lintian \
+ debian/$(cdbs_curpkg)/usr/share/lintian/overrides/$(cdbs_curpkg); \
+ fi
+ if test -e debian/$(cdbs_curpkg).presubj; then \
+ install -p -D -m644 debian/$(cdbs_curpkg).presubj \
+ debian/$(cdbs_curpkg)/usr/share/bug/$(cdbs_curpkg)/presubj; \
+ fi
+
+binary-install/$(DEB_SOURCE_PACKAGE)-doc-html::
+ set -e; \
+ for doc in `cd $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en; find . -name index.docbook`; do \
+ pkg=$${doc%/index.docbook}; pkg=$${pkg#./}; \
+ echo Building $$pkg HTML docs...; \
+ mkdir -p $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ cd $(CURDIR)/debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ /opt/trinity/bin/meinproc $(DEB_DESTDIR)/opt/trinity/share/doc/tde/HTML/en/$$pkg/index.docbook; \
+ done
+ for pkg in $(DOC_HTML_PRUNE) ; do \
+ rm -rf debian/$(DEB_SOURCE_PACKAGE)-doc-html/opt/trinity/share/doc/tde/HTML/en/$$pkg; \
+ done
+
+common-build-indep:: debian/stamp-kde-apidox
+debian/stamp-kde-apidox:
+ $(if $(DEB_KDE_APIDOX),+$(DEB_MAKE_INVOKE) apidox)
+ touch $@
+
+common-install-indep:: common-install-kde-apidox
+common-install-kde-apidox::
+ $(if $(DEB_KDE_APIDOX),+DESTDIR=$(DEB_DESTDIR) $(DEB_MAKE_INVOKE) install-apidox)
+
+cleanbuilddir::
+ -$(if $(call cdbs_streq,$(DEB_BUILDDIR),$(DEB_SRCDIR)),,rm -rf $(DEB_BUILDDIR))
+
+clean::
+ifndef _cdbs_class_cmake
+ if test -n "$(DEB_KDE_CVS_MAKE)" && test -d $(DEB_SRCDIR); then \
+ cd $(DEB_SRCDIR); \
+ find . -name Makefile.in -print | \
+ xargs --no-run-if-empty rm -f; \
+ rm -f Makefile.am acinclude.m4 aclocal.m4 config.h.in \
+ configure configure.files configure.in stamp-h.in \
+ subdirs; \
+ fi
+endif
+ rm -f .tdepkginfo
+ rm -f debian/stamp-kde-apidox
+ rm -f debian/stamp-cvs-make
+
+endif
diff --git a/debian/cdbs/versions.pl b/debian/cdbs/versions.pl
new file mode 100644
index 0000000..1b110f7
--- /dev/null
+++ b/debian/cdbs/versions.pl
@@ -0,0 +1,19 @@
+#!/usr/bin/env perl
+
+use strict;
+use warnings;
+
+my $version = `dpkg-parsechangelog | awk '/^Version/ {print \$2}'`;
+my ($version3, $version3_next);
+my ($version2, $version2_next);
+
+($version3 = $version) =~ s/^(([^.]+\.){2}[^.+~-]+)[.+~-]?[^-]*-[^-]+$/$1/;
+($version2 = $version3) =~ s/\.[^.]+$//;
+
+($version3_next = $version3) =~ s/(?<=\.)(\d+)[a-z]?$/($1+1)/e;
+($version2_next = $version2) =~ s/(?<=\.)(\d+)$/($1+1)/e;
+
+print "TDE-Version3=$version3\n";
+print "TDE-Version2=$version2\n";
+print "TDE-Next-Version3=$version3_next\n";
+print "TDE-Next-Version2=$version2_next\n";
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..aac5c9d
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,12 @@
+tdebluez (4:14.1.0-0debian10.1.1+eko1) unstable; urgency=low
+
+ * Build for buster.
+
+ -- Emanoil Kotsev <[email protected]> Sat, 02 Nov 2019 22:00:00 +0100
+
+tdebluez (4:14.1.0-0debian9.0.5+eko1) unstable; urgency=low
+
+ * Rework of Dbus interface to Bluez5 for TDE 14.1.
+
+ -- Emanoil Kotsev <[email protected]> Sat, 29 Sep 2018 22:00:00 +0100
+
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..ef9da49
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,70 @@
+Source: tdebluez
+Section: tde
+Priority: optional
+Maintainer: Debian TDE Team <[email protected]>
+Uploaders: ...
+Build-Depends: cdbs, debhelper (>= 9~), quilt, cmake-trinity, ninja-build, tdelibs14-trinity-dev, libdbus-1-tqt-dev, libdbus-1-3 (>= 1.10.26)
+Standards-Version: 3.8.0
+#Vcs-Svn: svn://svn.debian.org/pkg-kde/kde-extras/kdebluetooth/trunk/
+#Vcs-Browser: http://svn.debian.org/wsvn/pkg-kde/kde-extras/kdebluetooth/trunk/
+
+Package: tdebluez
+Section: tde
+Architecture: any
+Depends: ${shlibs:Depends}, bluez (>= 5.43), bluez-obexd (>= 5.43), tdelibs14-trinity, libdbus-1-tqt
+Suggests: pulseaudio-module-bluetooth
+Description: TDE Bluetooth Framework
+ The TDE Bluetooth Framework is a set of tools built on top of Linux' Bluetooth
+ stack BlueZ5. It provides easy access to the most common Bluetooth profiles and
+ makes data exchange with Bluetooth devices like phones and PDAs as
+ straightforward as possible.
+ .
+ Features:
+ * tdebluez -- a tray applet to handle incoming inquiries and control
+ adapters and devices
+ * tdebluezauth -- authentication agent
+ * tdeioclient -- cli to obex
+
+Package: libtdebluez
+Architecture: any
+Section: libs
+Replaces: libtdebluez (<< 0.1)
+Depends: ${shlibs:Depends}, bluez (>= 5.43)
+Description: Bluetooth library for TDE
+ This package is part of the TDE Bluetooth Framework.
+ It contains a Bluetooth library for TDE.
+ .
+ See the 'tdebluez' package for more informations.
+
+Package: libtdeobex
+Architecture: any
+Section: libs
+Replaces: libtdeobex (<< 0.1)
+Depends: ${shlibs:Depends}, bluez (>= 5.43), bluez-obexd (>= 5.43)
+Description: Obex library for TDE
+ This package is part of the TDE Bluetooth Framework.
+ It contains a Bluetooth library for TDE.
+ .
+ See the 'tdebluez' package for more informations.
+
+Package: libtdebluez-dev
+Architecture: any
+Section: libdevel
+Depends: libtdebluez (= ${binary:Version})
+Replaces: libtdebluez-dev (<< 0.1)
+Description: development files for libtdebluez
+ This package is part of the TDE Bluetooth Framework.
+ It contains the development files for libtdebluez.
+ .
+ See the 'tdebluez' package for more informations.
+
+Package: libtdeobex-dev
+Architecture: any
+Section: libdevel
+Depends: libtdebluez (= ${binary:Version})
+Replaces: libtdebluez-dev (<< 0.1)
+Description: development files for libtdebluez
+ This package is part of the TDE Bluetooth Framework.
+ It contains the development files for libtdebluez.
+ .
+ See the 'tdebluez' package for more informations.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..7fc5c09
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,43 @@
+This package was debianized by Emanoil Kotsev <[email protected]>
+on Fri, 19 Sep 2003 18:47:31 +0200.
+
+It was downloaded from http://bluetooth.kmobiletools.org
+
+Ported to TDE by Emanoil Kotsev <[email protected]>
+on Tue, 22 Nov 2016 17:23:21 +0100.
+
+Upstream Authors:
+
+ Emanoil Kotsev <[email protected]>
+
+Copyright:
+
+ (C) 2018 Emanoil Kotsev <[email protected]>
+
+License:
+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this package; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+
+On Debian systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL'.
+
+The documentations provided with kdebluetooth is distributed under
+the GNU Free Documentation License (FDL). They are considered free with
+regards to the Debian Free Software Guidelines (DFSG) because they don't
+contain any unmodifiable parts (invariant sections).
+
+On Debian systems, the complete text of the GNU Free Documentation
+License can be found in `/usr/share/common-licenses/GFDL'.
+
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..b43bf86
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1 @@
+README.md
diff --git a/debian/libtdebluez-dev.install b/debian/libtdebluez-dev.install
new file mode 100644
index 0000000..1593ff2
--- /dev/null
+++ b/debian/libtdebluez-dev.install
@@ -0,0 +1,2 @@
+opt/trinity/share/cmake/libtdebluez.cmake
+opt/trinity/include/tdebluez/*
diff --git a/debian/libtdebluez.install b/debian/libtdebluez.install
new file mode 100644
index 0000000..cba8c73
--- /dev/null
+++ b/debian/libtdebluez.install
@@ -0,0 +1,5 @@
+opt/trinity/lib/libtdebluez.so.0
+opt/trinity/lib/libtdebluez.so.0.0.1
+opt/trinity/lib/libtdebluez.so
+opt/trinity/lib/libtdebluez.la
+etc/trinity/dbus-1/system.d/org.trinitydesktop.tdebluez.conf /etc/dbus-1/system.d/
diff --git a/debian/libtdeobex-dev.install b/debian/libtdeobex-dev.install
new file mode 100644
index 0000000..0e91749
--- /dev/null
+++ b/debian/libtdeobex-dev.install
@@ -0,0 +1,2 @@
+opt/trinity/share/cmake/libtdeobex.cmake
+opt/trinity/include/tdeobex/*
diff --git a/debian/libtdeobex.install b/debian/libtdeobex.install
new file mode 100644
index 0000000..65642ce
--- /dev/null
+++ b/debian/libtdeobex.install
@@ -0,0 +1,4 @@
+opt/trinity/lib/libtdeobex.la
+opt/trinity/lib/libtdeobex.so
+opt/trinity/lib/libtdeobex.so.0
+opt/trinity/lib/libtdeobex.so.0.0.1
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..a6797f1
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,17 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/cmake.mk
+include debian/cdbs/debian-tde.mk
+
+DEB_CMAKE_EXTRA_FLAGS := \
+ -DCMAKE_EXPORT_COMPILE_COMMANDS="ON" \
+ -DCMAKE_INSTALL_PREFIX="/opt/trinity" \
+ -DCONFIG_INSTALL_DIR="/etc/trinity" \
+ -DSYSCONF_INSTALL_DIR="/etc/trinity" \
+ -DXDG_MENU_INSTALL_DIR="/etc/xdg/menus" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_VERBOSE_MAKEFILE="ON" \
+ -DCMAKE_SKIP_RPATH="OFF" \
+ -DBUILD_ALL="ON" \
+ -DWITH_ALL_OPTIONS="ON"
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/source/options b/debian/source/options
new file mode 100644
index 0000000..72f1f54
--- /dev/null
+++ b/debian/source/options
@@ -0,0 +1,6 @@
+# Use xz instead of gzip
+compression = "xz"
+compression-level = 9
+
+# Don't run differences
+diff-ignore = .*
diff --git a/debian/tdeblueplugd b/debian/tdeblueplugd
new file mode 100644
index 0000000..7d3db40
--- /dev/null
+++ b/debian/tdeblueplugd
@@ -0,0 +1,62 @@
+#!/usr/bin/python
+# -*- coding: UTF-8 -*-
+"""
+Copyright (C) 2007 Achim Bohnet <[email protected]>
+
+This program is free software; you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation; either version 2 of the License, or
+(at your option) any later version.
+"""
+
+import sys
+from PyQt4 import QtCore, QtGui
+import dbus
+#import dbus.mainloop.tqt3
+import dbus.mainloop.qt
+import distutils.spawn
+
+tdebtcmd = [ 'tdebluetooth' ]
+quitprogs = [ 'tdebluetooth', 'tdebluemon', 'tdeinputwizard' ] # FIXME: quit tdebluelock too?
+
+
+app = TQtGui.TQApplication(sys.argv)
+if app.isSessionRestored():
+ sys.exit(1)
+
+dbus.mainloop.qt.DBusQtMainLoop(set_as_default=True)
+bus = dbus.SystemBus()
+
+try:
+ manager = dbus.Interface(bus.get_object('org.bluez', '/org/bluez'), 'org.bluez.Manager')
+except:
+ print "Unable to connect to bluez."
+ sys.exit(1)
+
+if len(manager.ListAdapters()):
+ print "# of devices at startup:", len(manager.ListAdapters())
+ distutils.spawn.spawn(kbtcmd)
+else:
+ print "No BT device found"
+
+
+def slotAdapterAdded(device):
+ print "bt dev added:", device, "# of devices:", len(manager.ListAdapters())
+ distutils.spawn.spawn(kbtcmd)
+
+def slotAdapterRemoved(device):
+ print "bt dev removed:", device, "# num of devices:", len(manager.ListAdapters())
+ if len(manager.ListAdapters()) == 0:
+ for p in quitprogs:
+ print "exiting:", p, " ..."
+ try:
+ distutils.spawn.spawn(['dcop', p, 'MainApplication-Interface', 'quit'])
+ except:
+ pass
+
+manager.connect_to_signal("AdapterAdded", slotAdapterAdded)
+manager.connect_to_signal("AdapterRemoved", slotAdapterRemoved)
+
+print "waiting for bt device (un)plug events ..."
+app.exec_()
+#sys.exit(app.exec_())
diff --git a/debian/tdeblueplugd.desktop b/debian/tdeblueplugd.desktop
new file mode 100644
index 0000000..95d37e3
--- /dev/null
+++ b/debian/tdeblueplugd.desktop
@@ -0,0 +1,42 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=TDEBluetoothD
+Name[sv]=TDEbluetoothd
+Name[ta]=Kபுலுடுத்D
+Name[xx]=xxTDEBluetoothDxx
+GenericName=TDE Bluetooth Daemon
+GenericName[ar]=مراقب TDE Bluetooth
+GenericName[bg]=Демон за Bluetooth в TDE
+GenericName[br]=Diaoul TDE Bluetooth
+GenericName[bs]=TDE Bluetooth daemon
+GenericName[ca]=Dimoni Bluetooth de TDE
+GenericName[cs]=Bluetooth démon pro TDE
+GenericName[da]=TDE Bluetooth-dæmon
+GenericName[de]=TDE Bluetooth-Daemon
+GenericName[el]=Ο δαίμονας Bluetooth του TDE
+GenericName[es]=Daemon Bluetooth de TDE
+GenericName[et]=TDE Bluetoothi deemon
+GenericName[fr]=Démon TDE Bluetooth
+GenericName[gl]=Servizo Bluetooth de TDE
+GenericName[it]=Demone Bluetooth di TDE
+GenericName[ja]=TDE Bluetooth デーモン
+GenericName[ka]=TDE ბლუთუს დემონი
+GenericName[nl]=TDE Bluetooth-daemon
+GenericName[pa]=TDE ਬਲਿਊਟੁੱਥ ਡਾਈਮੋਨ
+GenericName[pl]=Demon Bluetooth dla TDE
+GenericName[pt]=Serviço Bluetooth do TDE
+GenericName[ru]=Служба TDE Bluetooth
+GenericName[sr]=Bluetooth демон за TDE
+GenericName[sr@Latn]=Bluetooth demon za TDE
+GenericName[sv]=TDE-Blåtandsdemon
+GenericName[ta]=TDE புலுடுத் டேமொன்
+GenericName[tr]=TDE Bluetooth Hizmeti
+GenericName[xx]=xxTDE Bluetooth Daemonxx
+Exec=tdeblueplugd
+Icon=TDEbluetooth
+Type=Application
+DocPath=TDEbluetooth/index.html
+Terminal=false
+X-TDE-autostart-after=panel
+X-TDE-StartupNotify=false
+X-TDE-autostart-condition=tdebluezrc:General:AutoStart:true
diff --git a/debian/tdebluez.install b/debian/tdebluez.install
new file mode 100644
index 0000000..2cb7792
--- /dev/null
+++ b/debian/tdebluez.install
@@ -0,0 +1,24 @@
+opt/trinity/bin/tdebluez
+opt/trinity/bin/tdebluezauth
+opt/trinity/bin/tdeioclient
+opt/trinity/lib/trinity/tdebluez.so
+opt/trinity/lib/trinity/tdebluez.la
+opt/trinity/lib/libtdeinit_tdebluez.so
+opt/trinity/lib/libtdeinit_tdebluez.la
+opt/trinity/lib/trinity/tdeio_bluetooth.so
+opt/trinity/lib/trinity/tdeio_bluetooth.la
+opt/trinity/lib/trinity/tdeio_obex.so
+opt/trinity/lib/trinity/tdeio_obex.la
+opt/trinity/share/apps/tdebluez/icons/*
+opt/trinity/share/doc/tde/HTML/*
+opt/trinity/share/apps/tdebluez/eventsrc
+opt/trinity/share/apps/tdebluez/tde-settings-network-bluetooth.directory
+opt/trinity/share/applications/tde/tdebluez.desktop
+opt/trinity/share/applications/tde/tdebluezauth.desktop
+opt/trinity/share/autostart/tdebluez.autostart.desktop
+opt/trinity/share/mimelnk/bluetooth/*
+opt/trinity/share/services/bluetooth.protocol
+opt/trinity/share/services/obexftp.protocol
+opt/trinity/share/services/obexopp.protocol
+opt/trinity/share/apps/konqsidebartng/virtual_folders/services/bluetooth_sidebarentry.desktop
+opt/trinity/share/apps/konqsidebartng/virtual_folders/services/obex_sidebarentry.desktop
diff --git a/debian/tdebluez.preinst b/debian/tdebluez.preinst
new file mode 100644
index 0000000..3a28f8c
--- /dev/null
+++ b/debian/tdebluez.preinst
@@ -0,0 +1,32 @@
+#!/bin/sh
+exit 0
+# Remove a no-longer used conffile
+rm_conffile ()
+{
+ PKGNAME="$1"
+ CONFFILE="$2"
+
+ if [ -e "$CONFFILE" ]; then
+ md5sum="`md5sum \"$CONFFILE\" | sed -e \"s/ .*//\"`"
+ old_md5sum="`dpkg-query -W -f='${Conffiles}' $PKGNAME | sed -n -e \"\\\\' $CONFFILE'{s/ obsolete$//;s/.* //p}\"`"
+ if [ "$md5sum" != "$old_md5sum" ]; then
+ echo "Obsolete conffile $CONFFILE has been modified by you."
+ echo "Saving as $CONFFILE.dpkg-bak ..."
+ mv -f "$CONFFILE" "$CONFFILE".dpkg-bak
+ else
+ echo "Removing obsolete conffile $CONFFILE ..."
+ rm -f "$CONFFILE"
+ fi
+ fi
+}
+
+# Last version that might have the obsolete conffile.
+LASTVERSION="0.1"
+case "$1" in install | upgrade)
+ echo "FIXME: tdebluez.preinstall Last version that might have the obsolete conffile"
+# if dpkg --compare-versions "$2" le "$LASTVERSION"; then
+# rm_conffile tdebluetooth /etc/kde3/obexrc
+# fi
+esac
+
+#DEBHELPER#
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..61fdcd4
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,9 @@
+# See uscan(1) for format
+
+# Compulsory line, this is a version 3 file
+version=3
+
+# Uncomment to find new files on sourceforge, for debscripts >= 2.9
+#opts=uversionmangle=s/_/-/,dversionmangle=s/~/-/ \
+# http://cryptomilch.de/~dgollub/kdebluetooth/kdebluetooth-(.*)\.tar\.bz2 debian svn-upgrade
+# http://sf.net/kde-bluetooth/kdebluetooth-(.*)\.tar\.gz debian svn-upgrade