summaryrefslogtreecommitdiffstats
path: root/src/libtdeobex/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/libtdeobex/CMakeLists.txt')
-rw-r--r--src/libtdeobex/CMakeLists.txt66
1 files changed, 66 insertions, 0 deletions
diff --git a/src/libtdeobex/CMakeLists.txt b/src/libtdeobex/CMakeLists.txt
new file mode 100644
index 0000000..c998ff0
--- /dev/null
+++ b/src/libtdeobex/CMakeLists.txt
@@ -0,0 +1,66 @@
+#################################################
+#
+# (C) 2018 Emanoil Kotsev
+# deloptes (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+project( libtdeobex )
+set(LIBRARY_VERSION 0.0.1)
+
+# include( ConfigureChecks.cmake )
+foreach( f ${TQT_LIBRARIES} )
+ if( ${f} STREQUAL "tqt-mt" )
+ set(TQUI_LIBRARIES "tqui" CACHE TYPE STRING FORCE)
+ endif()
+ if( ${f} STREQUAL "qt-mt" )
+ set(TQUI_LIBRARIES "qui" CACHE TYPE STRING FORCE)
+ endif()
+endforeach()
+
+# import required
+#tde_import( lib... )
+
+add_subdirectory( interfaces )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+ ${DBUS_INCLUDE_DIRS}
+ ${DBUS_TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+##### headers ###################################
+# implementations
+install(
+ FILES obexobjectmanagerImpl.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}/tdeobex )
+
+set( target tdeobex )
+
+set( ${target}_SRCS obexobjectmanagerImpl.cpp )
+
+
+##### tdeobex (shared) ###########################
+# set( KDE3_DCOPIDL_EXECUTABLE ${KDE3_DCOPIDLNG_EXECUTABLE} )
+tde_add_library( ${target} SHARED AUTOMOC
+ SOURCES ${${target}_SRCS}
+ VERSION ${LIBRARY_VERSION}
+ DEPENDS obexinterfaces-static
+ LINK ${DBUS_TQT_LIBRARIES} tdeparts-shared obexinterfaces-static ${TQUI_LIBRARIES}
+ DESTINATION ${LIB_INSTALL_DIR}
+ )
+
+##### install import cmake modules ###############
+tde_install_export( )