summaryrefslogtreecommitdiffstats
path: root/src/tdebluezauth/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/tdebluezauth/CMakeLists.txt')
-rw-r--r--src/tdebluezauth/CMakeLists.txt47
1 files changed, 47 insertions, 0 deletions
diff --git a/src/tdebluezauth/CMakeLists.txt b/src/tdebluezauth/CMakeLists.txt
new file mode 100644
index 0000000..055779d
--- /dev/null
+++ b/src/tdebluezauth/CMakeLists.txt
@@ -0,0 +1,47 @@
+#################################################
+#
+# (C) 2018 Emanoil Kotsev
+# deloptes (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+project( tdebluezauth )
+
+# import required
+#tde_import( lib... )
+
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/src/libtdebluez
+ ${CMAKE_BINARY_DIR}/src/libtdebluez
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+# ${DBUS_INCLUDE_DIRS}
+ ${DBUS_TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+##### tdebluezauth (tdeinit) ######################
+
+tde_add_executable( tdebluezauth AUTOMOC
+ SOURCES
+ authorize.cpp authdialog.ui
+ pindialog.cpp pindefdialog.ui
+ authservice.cpp application.cpp main.cpp
+ LINK
+ ${DBUS_TQT_LIBRARIES} tdebluez-shared bluezinterfaces-static
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+##### other data ################################
+#tde_install_icons( tdebluezauth )
+install( FILES tdebluezauth.desktop DESTINATION ${XDG_APPS_INSTALL_DIR} )