summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2021-07-26 17:30:04 +0200
committerSlávek Banko <[email protected]>2021-07-26 17:30:16 +0200
commitc168c9641cf897c7441a040678121378662ef01c (patch)
tree8d0d58f09a0a06e727863ac45239cf0d48415a50 /CMakeLists.txt
parent2271dae6de2549abbc3a52a14c106510d460bd58 (diff)
downloadtdedocker-c168c9641cf897c7441a040678121378662ef01c.tar.gz
tdedocker-c168c9641cf897c7441a040678121378662ef01c.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <[email protected]> (cherry picked from commit 9d7fc4700e86be84e382f7f13b34b14100d55063)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c16c65c..76aeab5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -72,10 +72,11 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
add_subdirectory( icons )
add_subdirectory( src )
-tde_conditional_add_subdirectory( BUILD_DOC man )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
##### other data ################################
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
+
tde_create_translated_desktop( tdedocker.desktop )