summaryrefslogtreecommitdiffstats
path: root/atlantik/libatlantikclient/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Golubev <[email protected]>2016-02-25 06:23:55 +0300
committerSlávek Banko <[email protected]>2016-03-14 23:04:46 +0100
commit22eaaf46994712a7ea19be99d49c5ceb889470bd (patch)
tree6813293435ece498f1d90a99adfa5e9a49c875fe /atlantik/libatlantikclient/CMakeLists.txt
parentfa5d2dca53e1046fe38ac7cf0210d45ad5cc5107 (diff)
downloadtdegames-22eaaf46994712a7ea19be99d49c5ceb889470bd.tar.gz
tdegames-22eaaf46994712a7ea19be99d49c5ceb889470bd.zip
Initial cmake conversion
(cherry picked from commit c70db62d3671e524d23ac974d296eb218159b000)
Diffstat (limited to 'atlantik/libatlantikclient/CMakeLists.txt')
-rw-r--r--atlantik/libatlantikclient/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/atlantik/libatlantikclient/CMakeLists.txt b/atlantik/libatlantikclient/CMakeLists.txt
new file mode 100644
index 00000000..53d2a932
--- /dev/null
+++ b/atlantik/libatlantikclient/CMakeLists.txt
@@ -0,0 +1,34 @@
+#################################################
+#
+# (C) 2016 Alexander Golubev
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+##################################################
+
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/atlantik/libatlantic
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### atlantikclient (shared) ###################
+
+tde_add_library( atlantikclient SHARED AUTOMOC
+ SOURCES atlantik_network.cpp monopdprotocol.cpp
+ VERSION 3.0.2
+ LINK tdeio-shared atlantic-shared
+ DESTINATION ${LIB_INSTALL_DIR}
+)