summaryrefslogtreecommitdiffstats
path: root/kasteroids/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Golubev <[email protected]>2016-02-25 06:23:55 +0300
committerSlávek Banko <[email protected]>2016-03-14 23:04:46 +0100
commit22eaaf46994712a7ea19be99d49c5ceb889470bd (patch)
tree6813293435ece498f1d90a99adfa5e9a49c875fe /kasteroids/CMakeLists.txt
parentfa5d2dca53e1046fe38ac7cf0210d45ad5cc5107 (diff)
downloadtdegames-22eaaf46994712a7ea19be99d49c5ceb889470bd.tar.gz
tdegames-22eaaf46994712a7ea19be99d49c5ceb889470bd.zip
Initial cmake conversion
(cherry picked from commit c70db62d3671e524d23ac974d296eb218159b000)
Diffstat (limited to 'kasteroids/CMakeLists.txt')
-rw-r--r--kasteroids/CMakeLists.txt50
1 files changed, 50 insertions, 0 deletions
diff --git a/kasteroids/CMakeLists.txt b/kasteroids/CMakeLists.txt
new file mode 100644
index 00000000..ecdbdbb5
--- /dev/null
+++ b/kasteroids/CMakeLists.txt
@@ -0,0 +1,50 @@
+# This file is genereted by trinity-automake-cmake-convert script by Fat-Zer
+
+add_subdirectory( sprites )
+add_subdirectory( sounds )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/libtdegames
+ ${CMAKE_SOURCE_DIR}/libtdegames/highscore
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### kasteroids (executable) ###################
+
+tde_add_executable( kasteroids AUTOMOC
+ SOURCES main.cpp view.cpp ledmeter.cpp toplevel.cpp settings.kcfgc
+ LINK tdecore-shared tdeui-shared tdeio-shared tdegames-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### icons #####################################
+
+tde_install_icons( kasteroids )
+
+
+##### other data ################################
+install( FILES kasteroids.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)
+
+install( FILES kasteroidsui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/kasteroids
+)
+
+install( FILES kasteroids.kcfg
+ DESTINATION ${KCFG_INSTALL_DIR}
+)
+
+install( FILES bg.png
+ DESTINATION ${DATA_INSTALL_DIR}/kasteroids/sprites
+)