summaryrefslogtreecommitdiffstats
path: root/kenolaba/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Golubev <[email protected]>2016-02-25 06:23:55 +0300
committerSlávek Banko <[email protected]>2016-03-14 23:04:46 +0100
commit22eaaf46994712a7ea19be99d49c5ceb889470bd (patch)
tree6813293435ece498f1d90a99adfa5e9a49c875fe /kenolaba/CMakeLists.txt
parentfa5d2dca53e1046fe38ac7cf0210d45ad5cc5107 (diff)
downloadtdegames-22eaaf46994712a7ea19be99d49c5ceb889470bd.tar.gz
tdegames-22eaaf46994712a7ea19be99d49c5ceb889470bd.zip
Initial cmake conversion
(cherry picked from commit c70db62d3671e524d23ac974d296eb218159b000)
Diffstat (limited to 'kenolaba/CMakeLists.txt')
-rw-r--r--kenolaba/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/kenolaba/CMakeLists.txt b/kenolaba/CMakeLists.txt
new file mode 100644
index 00000000..e5398246
--- /dev/null
+++ b/kenolaba/CMakeLists.txt
@@ -0,0 +1,42 @@
+# This file is genereted by trinity-automake-cmake-convert script by Fat-Zer
+
+add_subdirectory( toolbar )
+add_subdirectory( bitmaps )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/libtdegames
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### kenolaba (executable) #####################
+
+tde_add_executable( kenolaba AUTOMOC
+ SOURCES Board.cpp Move.cpp BoardWidget.cpp AbTop.cpp kenolaba.cpp Spy.cpp
+ Ball.cpp Network.cpp EvalDlg.ui EvalDlgImpl.cpp EvalScheme.cpp
+ LINK tdecore-shared tdeui-shared tdeio-shared tdegames-shared
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### icons #####################################
+
+tde_install_icons( kenolaba )
+
+
+##### other data ################################
+install( FILES kenolabaui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/kenolaba
+)
+
+install( FILES kenolaba.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)