summaryrefslogtreecommitdiffstats
path: root/kfouleggs/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <[email protected]>2020-06-10 21:25:06 +0200
committerSlávek Banko <[email protected]>2020-06-12 14:19:33 +0200
commita25cdc59c6302046b3121276f5a33f6b1b55a538 (patch)
tree5c41c38d0c81e99bfe2d3a8564af42cc2d92941f /kfouleggs/CMakeLists.txt
parentdc556f3e9a46e749b36cf773f9211db4ce58d96b (diff)
downloadtdegames-a25cdc59c6302046b3121276f5a33f6b1b55a538.tar.gz
tdegames-a25cdc59c6302046b3121276f5a33f6b1b55a538.zip
Desktop file translations:
+ Creation of POT template for desktop files added to CMakeL10n rules. + Added creation of translated desktop files during build. Signed-off-by: Slávek Banko <[email protected]>
Diffstat (limited to 'kfouleggs/CMakeLists.txt')
-rw-r--r--kfouleggs/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/kfouleggs/CMakeLists.txt b/kfouleggs/CMakeLists.txt
index ae0b2f69..3cbc9ca7 100644
--- a/kfouleggs/CMakeLists.txt
+++ b/kfouleggs/CMakeLists.txt
@@ -48,10 +48,10 @@ install( FILES kfouleggs.kcfg
DESTINATION ${KCFG_INSTALL_DIR}
)
-install( FILES eventsrc
+tde_create_translated_desktop(
+ SOURCE eventsrc
DESTINATION ${DATA_INSTALL_DIR}/kfouleggs
+ PO_DIR ${CMAKE_SOURCE_DIR}/translations/desktop_files/kfouleggs-eventsrc
)
-install( FILES kfouleggs.desktop
- DESTINATION ${XDG_APPS_INSTALL_DIR}
-)
+tde_create_translated_desktop( kfouleggs.desktop )