summaryrefslogtreecommitdiffstats
path: root/kpat/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Golubev <[email protected]>2016-02-25 06:23:55 +0300
committerSlávek Banko <[email protected]>2016-03-14 23:04:46 +0100
commit22eaaf46994712a7ea19be99d49c5ceb889470bd (patch)
tree6813293435ece498f1d90a99adfa5e9a49c875fe /kpat/CMakeLists.txt
parentfa5d2dca53e1046fe38ac7cf0210d45ad5cc5107 (diff)
downloadtdegames-22eaaf46994712a7ea19be99d49c5ceb889470bd.tar.gz
tdegames-22eaaf46994712a7ea19be99d49c5ceb889470bd.zip
Initial cmake conversion
(cherry picked from commit c70db62d3671e524d23ac974d296eb218159b000)
Diffstat (limited to 'kpat/CMakeLists.txt')
-rw-r--r--kpat/CMakeLists.txt54
1 files changed, 54 insertions, 0 deletions
diff --git a/kpat/CMakeLists.txt b/kpat/CMakeLists.txt
new file mode 100644
index 00000000..e1399487
--- /dev/null
+++ b/kpat/CMakeLists.txt
@@ -0,0 +1,54 @@
+#################################################
+#
+# (C) 2016 Alexander Golubev
+# fatzer2 (AT) gmail.com
+#
+# Improvements and feedback are welcome
+#
+# This file is released under GPL >= 2
+#
+#################################################
+
+add_subdirectory( icons )
+add_subdirectory( freecell-solver )
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_SOURCE_DIR}/libtdegames
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### kpat (executable) #########################
+
+tde_add_executable( kpat AUTOMOC
+ SOURCES main.cpp cardmaps.cpp card.cpp dealer.cpp pwidget.cpp pile.cpp
+ deck.cpp pile_algorithms.cpp kings.cpp freecell.cpp klondike.cpp simon.cpp
+ grandf.cpp mod3.cpp idiot.cpp napoleon.cpp computation.cpp gypsy.cpp
+ fortyeight.cpp yukon.cpp clock.cpp golf.cpp spider.cpp gamestatsimpl.cpp
+ gamestats.ui
+ LINK tdecore-shared tdeui-shared tdeio-shared tdegames-shared fcs-static
+ DESTINATION ${BIN_INSTALL_DIR}
+)
+
+
+##### other data ################################
+
+install( FILES green.png
+ DESTINATION ${DATA_INSTALL_DIR}/kpat/backgrounds
+)
+
+install( FILES kpatui.rc
+ DESTINATION ${DATA_INSTALL_DIR}/kpat
+)
+
+install( FILES kpat.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)